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Getting Started 3

1 Getting Started

1.1 Introduction
Welcome to VisiTrax!

Note: To completely view this and other Help topics, you may need to scroll down by
moving the vertical scroll bar on the right margin, or by pressing scroll keys
such as down-arrow and up-arrow.

Piles and piles of CDs..records...tapes. Including titles like "Billboard Top Rock'n'Roll Hits..." by nobody
in particular. "Hey, where was that one we had by ...? | know we had it on one of these CDs around
here somewhere..."

Objective: Spend less time looking for music and more time enjoying it.
Solution:  VisiTrax™

Whether you make a living as a DJ or just want the fastest possible way to find music, VisiTrax is
designed for you.

VisiTrax has the following key features:

¢ Simple browsing and data entry — including automatic CD title lookups via gnudb.org.

e Integrates with Winamp v5 to organize and play your MP3 and other audio files.

¢ Fast, convenient track-oriented data lookup. You'll see all your tracks, sorted the way you want, right
from the start!

¢ Virtually instantaneous filtering by track characteristics (artist, title, category, time, year, media
format, etc.).

e Intuitive volume-oriented data entry, with track-specific artists, years, and categories.

¢ No preset lists of categories or media formats — use any names you want.

o Efficient relational database engine built in, with fully automatic list management.

¢ Flexible, professional-appearing data printouts, with print preview.

¢ Printable playlists can be extracted from your library quickly and easily, complete with elapsed time
information.

e Supports use of SureThing CD Labeler for printing CD labels and jewel case inserts.

e Supports quick data export to DJIntelligence.com and GigBuilder.com (a WeDJ.com subsidiary
site).

o Multi-level undelete. Easily recover accidentally deleted track or volume records.

e Convenient on-line Help. If you need specific help on any VisiTrax feature, just press the F1 key.

If you're just getting started with VisiTrax, please see Library Concepts and Overview.

See also: Compatibility
Installed Files

End-User License Agreement
Uninstalling VisiTrax

VisiTrax™ and this documentation are Copyright © 1999-2023 Synapsa Productions. All rights
reserved.
VisiTrax™ and Synapsa™ are trademarks of Synapsa Productions.
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1.2

Installation and Configuration

Installed Files

The following files are placed in your VisiTrax directory during installation:

VisiTrax.exe The VisiTrax program itself

VisiTrax.chm This on-line Help file

Example.trx  An example music library

CDlabels.std A sample design file for printed CD labels
ReadMe.txt  Text file containing general product description

User Preference Settings

Most day-to-day VisiTrax user settings, such as sizing, font, and color preferences, are automatically
maintained in your Windows user profile. For an overview of available settings, see View Options and

Customization.

Internet and Proxy Settings

Selecting Internet Settings... from the View menu will present the following dialog:

Internet Settings x|
 Proxg Settings

= Automatic Configuratian
& Use Specified Prosy Server
= Mo Prosy

Address: Iprm:yservername Part: IBDBD

¥ Use HTTP 1.1 protocol [recommended)
x Cancel |

In the Proxy Settings section, you can select one of the following:

Automatic Configuration This option is recommended for most situations. VisiTrax will try to
use the same HTTP proxy settings as your browser.

Use Specified Proxy Server If your browser uses a proxy configuration script, or if VisiTrax is
otherwise unable to determine your browser's settings automatically, you
can use this option to specify the proxy address and port.

No Proxy If you don't want VisiTrax to use a proxy server, regardless of your browser's
proxy settings, select this option. If you use a cable modem or DSL and your
ISP recommends using their (optional) proxy server for your browser,
selecting No Proxy here may provide better results — as a given CD data
server could mistakenly interpret a large number of users sharing a single
proxy server as a single, very busy individual, and limit daily accesses
accordingly.

The Use HTTP 1.1 protocol checkbox specifies whether to use the HTTP 1.1 protocol when
accessing CD data server sites. Because HTTP 1.1 is intrinsically more reliable than the older HTTP
1.0 protocol, you should always try to use HTTP 1.1 if possible, by leaving this checkbox checked.
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1.3

1.4

1.5

Even if a given CD data server supports HTTP 1.1 quite nicely, you may need to clear this checkbox
(for HTTP 1.0) if your network connection to that server passes through an intermediate proxy server
that still uses HTTP 1.0 — this can sometimes be the case notwithstanding your own proxy settings.

Backup and Migration

Backing Up Your Data

Just as it's a good idea to frequently save your work while working in VisiTrax, you'll want to be sure all
your long-term work is not lost if you have an equipment failure or other disaster. At a minimum, here
is the VisiTrax data you'll want to keep backed up and saved in a safe location:

e Our web site address (www.synapsa.com) — this is your VisiTrax program backup!
e Your VisiTrax library data and any playlists (*.trx, *.vxp, and possibly *.txt).

Migrating VisiTrax to a New Computer

Migrating VisiTrax to a new computer is much like migrating other software. Here's the recommended
procedure:

1) Download the latest version of VisiTrax from our web site (www.synapsa.com) and install it on the
new computer.

2) Transfer your VisiTrax library files and any playlists (*.trx, *.vxp, and possibly *.txt) to the new
computer.

3) Open your transferred library file (.trx).

Note: If you are using a CD-ROM to transfer your backed up data, note that files copied from a
CD-ROM, on some PCs, will end up being set to read-only by default. If this happens, VisiTrax
will not be able to update them. To correct this, change the attributes of your transferred data
files so they are not "read only” (this can be done with Explorer or from a command prompt).

See also: Supported File Formats
Saving Your Changes

Uninstalling VisiTrax

To remove VisiTrax from your computer, run Control Panel | Add/Remove Programs, then select
VisiTrax from the list and click the OK button.

VisiTrax will attempt to use your original configuration settings if you subsequently install the program
again.

Note: Before installing an updated version of VisiTrax, you may wish to remove (uninstall) the older
version first; however, this is not usually required.

Product Support

For the latest information about VisiTrax, please visit our web site at www.synapsa.com.

Comments, questions, and suggestions are welcomed, and can be sent via e-mail to
support@synapsa.com. A comment form also is available on our web site's feedback page.
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1.6

2.1

Compatibility

VisiTrax provides the key capabilities found in its DOS-based predecessor, Playlist 4.03, including
support for existing Playlist library database files.

To facilitate exchanging data with other recording library database applications, VisiTrax can exchange
data with common spreadsheet applications via copy and paste, and also can import/export data as
text files.

If you require assistance migrating your existing music library data to VisiTrax, please contact us via
e-mail at support@synapsa.com.

See also: Supported File Formats

Using VisiTrax

Library Concepts and Overview

Basic Library Model

VisiTrax supports a consistent and straightforward library model, in which any recording library is
treated as a set of identifiable volumes, each containing one or more individual tracks. Both volumes
and tracks can be assigned numbers for quick reference.

Volume Numbering (Locator Indexing)

The volume numbering method used by VisiTrax is simple, yet very effective for keeping a growing
library physically organized. Each volume can be assigned a unique locator index, displayed primarily
in the form AANNNN, where AA denotes a pair of letters you assign for each media format, and
NNNN denotes four digits, as in "CD0234".

To support multi-volume sets, such as a CD jewel case containing a set of 3 CDs, you can use the
extended form AANNNN.D, where D is a single digit from 1 to 9. By using this numbering method, you
can assigh numbers such as CD0230.1, CD0230.2, and CD0230.3 to the individual discs, labeling the
case containing them as CD0230.

The easiest way to use volume numbers is simply to assign them in sequence (regardless of title or
artist), keep things physically arranged by assigned volume number, and let VisiTrax take care of
alphabetization. To look things up alphabetically without your computer, just keep an alphabetized
VisiTrax printout handy.

Since VisiTrax automatically keeps track of all unused index numbers, it's also easy to assign distinct
index numbers even when they're not strictly in sequence. For example, if you wish to divide your
index numbers into special groupings (e.g. CD0001-CD1999, CD2000-CD4999, etc.), you'll be able to
select the next available index in each such range, without having to type it in. This is explained in our
topic on adding a new volume.

Note that VisiTrax has a handy feature that lets you resequence a range of volume index numbers.
This also can be used to automatically assign index numbers to a group of nhon-numbered volumes.
(See Volumes View.)

Although assigning locator indexes is optional, it's very easy to do in VisiTrax, and your listings will
tend to be more useful. For example, if you sequentially label and arrange your CDs by locator index
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as suggested above, it's much easier to find where a particular CD belongs, or to spot a missing CD.

Track Indexing

Within a given volume, each track can be assigned a track number. This of course is quite natural for
media such as CDs and album sides, for which sequential track nhumbering is standard.

By combining track indexing with volume locator indexing, you have a very concise and consistent way
to represent any track in your library. For example, "CD0532-2" would indicate track 2 on the volume
identified as CD0532. In a box of singles or a set of videos, you might want the track index number to
refer to an individual single or video, so that, for example, "SG0032-46" would be the single in box 32,
slot 46. (Alternatively, for videos, you might wish to assign a volume number to each one, and use
tracks to contain detailed information such as producer, director, cast members, and so on.)

For two-sided media, such as phonograph records or tape cassettes, you can use the letter A or B
before or after the index number to denote side A or B. For example, you might have an LP album with
tracks indexed as A1-A8 and B1-B12, or a box of single 45 RPM records indexed as 1A, 1B, 2A, 2B,
and so on. For a multi-disc album, a given track might then be fully identified, for example, as
"LP0123.1-A2" — meaning disc 1, side A, second track, of the album identifed as "LP0123".

VisiTrax allows two or more track entries to share the same index number. This might be useful, for
example, if you have a track commonly attributed to two or more different artist names: just make two
entries for the same track, each with its own artist name. [Index number "0", by the way, means "no
assigned index" (same as blank).]

Track index numbers can range from 1 to 9999, Al to A9999, B1 to B9999, or 1A to 9999B.

Viewing Your Library

VisiTrax provides three distinct types of views into your entire library database:

e The Tracks View lists every track contained in the library, or a filtered subset, sortable by any set of
columns.

e The Volumes View lists every volume contained in the library, or a filtered subset, sortable by any
set of columns.

e The Volume Contents View lists the tracks belonging to a particular volume, sorted primarily by
track index number.

These views are easily accessible via multi-sheet tabs, as shown below. To access a desired view,
simply click on its tab (or use the corresponding View menu option, Ctrl-Tab, or the left/right-arrow

keys).
InJUlfIIU run
Tracks | Yolumes I Yolume Contents
Playlists

Another view, accessed via the Playlist tab as shown below, supports working with playlists. Clicking
this tab will display a Playlist View, which lists the contents of a selected subset of tracks (a playlist),
sorted by playing sequence.

IJethrn Tull Crest of a Knave

Tracks Volumez | Yolume Enntentsl Playlist I

An Example Library

To help you get started, we've included an example library database named Example.trx. When you
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install VisiTrax for the first time, this example library is opened for you automatically. To access it later
on, simply open it and you'll be greeted with a view listing its contents.

NOTE — Be sure to save your own library data to its own file, not to the example library file!

Entering and Changing Library Data

To enter new data into your library, you can start with an existing library file, or you can start a new
library file from scratch. You can then create a new volumeentry for each CD, album, etc. Once a
new volume entry is created, you can populate it with one or more new track entries. If you have a
CD-ROM drive and an Internet connection, the CD Player View can be used to quickly add CDs to
your library database, often with little or no typing required on your part. If Winamp v5 is installed on
your PC, you also can quickly import MP3 and other audio file tracks from its playlist directly into
your VisiTrax database.

Lastly, you can update an existing volume or update an existing track at any time, undelete
volumes or tracks you've just deleted by accident, and exchange data between VisiTrax and other
applications.

Tracks View

The Tracks View lists all of the tracks contained in the library, as shown below. This is likely to be the
view you will use most often, as it's the one you use to locate one or more tracks of interest.

VisiTrax Lite - C:\Synapsa Productions\VisiTrax\Music.trx [;]@
File Edit View Sorting Extras Help
L= e Res e (SN RV RS T Rl
tedia Format; |I:DmpactDisc ﬂ Artist: | j
Categomny: |Fh:|ck ﬂ Title: | j
Composer; | ﬂ MHotes: | j
Year Artist | Track Title | Tme | vear| Locaton [
| |B-52= Iz That %ou Mo-Dean? 5:32| 1892 |[CD0241-6
BEM B-5Z'= Junebug 504 1839 |CDOO0S-5
= B-52= Private idaho 335 Cho3zz-4
I
Z‘ J B-5Z'= Rewvolution Earth S48 1992 CDOZa1-4
z B-52'= Roam ¥ 4:54| 1839 |CDOO0DS-5
bdas Time -
,7 .|| |B-52's Tell it Like i T-H= 513 1892 |CDO241-41
1| fB-52'= Topaz 4:20 1535 CDOO0DG-9
b ax - Min B-52's Vigion of a Kiss 5:57 | 1992 CDO241-8
-15 i‘ Bangles Walk Like An Egyptian 3:25| 1886 |CDO279-9
Bauhaus Ziggy Stardust 315 1832 |CD0O334-15
Beach Boys All Summer Long 2:08| 1863 CDOOOT-20
Beach Boys Be True to Your School 2:07| 1983 CDOOOT-8 w
Show Al - =l
Tracks |Uolumes] Volume Contents I Pla'_.rljst] CcD Pla'_.rerl
COO00E-3 [Rock] Playlist total = 1:16:25 |Tracks: 1361 / 6531

On startup, tracks in this view will appear in a grid, sorted from left to right (i.e. the leftmost column is
the primary sort key). To change the sort ordering, click on the corresponding column header, or make
a selection via the Sorting menu. Sorting is based on the most recent set of columns selected for
sorting, with precedence given to the most recently selected columns.

To quickly reset sorting precedence based on current column ordering, click the % button (sort
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across).

Above and to the left of the listing grid is a set of filter controls you can use for looking up data almost
instantly, with a minimum of guesswork. Filter controls limit the listing to a desired subset (as depicted
in the example above). Initially, no filters will be selected, so that all tracks in the library will be listed.
Filtering is discussed at length further down in this topic.

Navigating the List

You can scroll through the list of tracks as you would with any standard Windows listbox. If you click on
a particular track (or use the up- or down-arrow keys to do the same thing), it becomes highlighted, as
shown above, and additional information for that track is displayed on the status bar at the bottom left.
As you can see in the example, this reveals the complete location index of the track, its category, and
tempo in beats per minute (bpm).

The right-hand section of the status bar indicates the number of tracks in the list, followed by the total
number of tracks in the library, as shown in the example.

If you double-click on a selected track, or press the space bar, VisiTrax will switch to the
corresponding Volume Contents View for the volume in which the selected track resides.

A checkmark symbol denotes a track that has been entered into a playlist, in the current session.
Since there is an active playlist, the Playlist view tab is shown, and the middle status bar section
indicates the total playlist time.

Additional Data Columns

The Tracks view includes many additional data columns that you don't normally see — including all of
the columns available in the Volumes view. To access these additional columns, simply scroll to the
right using the horizontal scroll bar at the bottom of the listing. These additional columns are always
available, and you are free to move any columns in or out of the main set. For more information on
how to do this, see Changing Which Columns You See.

Note that some columns contain data for which there are no manual data entry fields, either because
the data is automatically computed (e.g. Disc ID and Vol Time), or because it's simply an alternate
data representation (e.g. Location).

Shortcuts:

¢ While in the listing, typing the first part of the track's artist name or title will scroll the list to the first
matching entry (depending on current column sort precedence). A one-second pause in typing starts
a new sequence.

¢ Function key F2 (also Enter) returns focus to the list in the current view.

e Function key F3 will clear all filters.

¢ Function key F4 will activate a filter field's menu (as applicable).

e Function keys F5 - F11 (some with shift) provide shortcuts to each of the primary filter fields.

Playing MP3 and other Audio Files

If the currently highlighted track is linked to an MP3 or other audio file, clicking the ﬂ toolbar button
will initiate play of that file — either by Winamp, if you have Winamp v5 installed on your PC, or
otherwise by the file's associated media player program (if any).

Using Track Filtering Controls to Locate Tracks

The Tracks view provides an assortment of filtering controls for constraining the list of tracks to just the
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ones you are interested in viewing. This is a powerful mechanism for quickly locating material.

The filtering controls described below can be hidden or restored via the E toolbar button (or by
selecting Filters from the View menu). The available controls are described as follows:

Media Format Use this to view only those tracks residing on volumes of a particular media format.

Category

Artist

Composer

Title

Notes

Year

BPM

Max Time

(Note: This is functionally identical to the Media Format filter in the Volumes view.
We include it in the Tracks view for convenience, even though media format is
actually a volume attribute.)

Use this to view a particular subset of track categories (music types etc.). If you
have, say, several flavors of "Rock" categories, note that you can select all of them
by using wildcards (e.g. "..rock.." or "=rock=").

Use this to view a particular track artist or subset of artist names.
Use this to view tracks by a particular composer or subset of composer names.

Use this to view a particular track title or subset of titles. The wildcard feature is
particularly useful here if you're not certain of a title, or if you want some theme (e.g.
"..sun.." or "=sun=").

Use this to view tracks based on the content of their notes.

If you're looking for tracks from a specific year, just type it in here. If you want to view
anything in a specific range of years, use the form "1960-1967" — also equivalent
here are "1960-67" and "1960-7". If you want to view anything at or after a given
year, use the form "1990-". If you want anything at or before a given year, use the
form "-1990".

If you want to view just the non-dated tracks, enter "0". [Since dates aren't always
readily available, you might want to add tracks from time to time without the year,
returning later when you have more time to dig up the information. This particular
filter entry could come in handy at such times.]

Conversely, if you want to view all the dated tracks, you can enter "1-" or just

For convenience, a drop-down list of decades (starting with 1900-1909) also is
provided.

Use this to view only those tracks at a particular beat rate, or range of rates, in beats
per minute (bpm). Desired BPM can be entered in one of two ways:

e To specify a particular BPM rate, or a range of rates, type it in the same way as
for Year, above.

¢ To specify a nominal BPM plus or minus some tolerance value, e.g. 110 £ 5, click
the & button. This will activate an additional tolerance value field.

The most common use for this filter is in a situation where you have a limited
amount of playing time to deal with, such as the remaining time in a program, on a
tape side, or on a recordable CD. Thus, the maximum available time is of primary
interest.

Playing time selection is handled as two fields. Enter the maximum time of interest in
the Max Time field. The Max - Min field specifies how much slack is acceptable; the
default entry here is 15 seconds. So, for example, if the first field contained 4:00 and

Copyright 1999-2023 Synapsa Productions



Using VisiTrax 11

the second field contained :15, the range of times viewed would be 3:45 to 4:00.

Show All To show all available tracks, click on this button. This will clear all of the filters at
once.

Several additional filters are available in the Volumes view. These additional filters also affect the
Tracks view listing content.

General Filtering Notes

(1) As shown in the example above, -any- is simply a placeholder hint indicating that no filter is
specified. Any time you clear any of these controls, this placeholder is substituted. When you
enter the control, the -any- will disappear so you can make your entry.

(2) A down-pointing arrow button on the right side of a filter field indicates a drop-down list, from
which you can select as an alternative to typing something in.

(3) You can remove any individual filter by double-clicking on it.

(4) You canremove all filters by clicking the ‘& toolbar button.

(5) If you are working with a playlist, you can click the ﬂ toolbar button to set (or clear) a filter for
viewing only those items contained in the current playlist.

(6) You can click the % toolbar button to set (or clear) a filter for viewing only those items linked to
an MP3 or other playable audio file.

(7) You can use one or more wildcards in a filter, using either an equal sign ("=") or a pair of dots ("
.."). Here are some examples:

B.. orB= Anything beginning with a "B"

.D or=D Anything ending with a "D"

B..D or B=D Anything beginning with "B" and ending with "D"
or =day= Anything containing "day" in it somewhere

day..

" or = Anything (same as no filter at all)

(8) You can specify a combination of two or more logical OR filter alternatives using a pair of
vertical bars ("||"), as in these examples:

Folk || Celtic  Select both "Folk" and "Celtic" categories

Yardbirds || Select both "Yardbirds" and anything beginning with "Clapton”
Clapton=

red =||= red =||= Select only those items containing the whole word "red"

red

(9) Similarly, you can specify a required combination (logical AND) using a pair of ampersands ("
&&"); for example:

=blue= && Select all items containing both "blue" and "sky"
:Sky:

(10) A logical NOT operator (") also is available. For example:

=green=&&"=gr Select all items containing "green" but not "grass"
ass=
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2.3

(12) Allfilters are case-insensitive.
(12) The listing grid updates automatically as you make any filtering changes.

(13) The combined filters from both the Tracks view and Volumes view are applied in concert, thus
filters set in either of these views can affect contents displayed in the other.

See also: View Options and Customization
Copying to the Clipboard
Printing and Print Preview
Volumes View

Exporting Data

Volumes View

The Volumes View lists the volumes contained in the library (subject to any viewing filters you might
have set), as shown below. This is the view you would use for adding, deleting, or updating volume
entries.

I3 VisiTrax Lite - C:\Synapsa Productions\VisiTrax\Music.trx [;]@
File Edit View Sorting Extras Help
b e [H B U BB | e |
tedia Format; |I:Dmpact Digc ﬂ Artigt: | j
Categon: | ﬂ Title: | j
Index; | ear | ﬂ Motes: | -
Volume Artist | Volume Title | volume category | volvr | index  |a]
Aerosmith Get A Grip Rock 1884 |cD0242 | =]
Aerosmith Pump Rock v'| 1989 |CDOODZ
Alan Parzong Project Best of the Alan Parsons Proj... Rock 1883 | CDOOO3
Alan Parsons Project Gaudi Rock v'| 1987 |CDOOD4
Alice Cooper Alice Cooper's Greatest Hite  Rock 1873 |CDOOOS
B-52'= Cosmic Thing Rock v 1989 CDOOD&
B-52= Good Stuff Rock 1852 |CDO241
Beach Boys Endiess Summer Rock 1955 | CDOOOT
Beatles Abbey Road Rock 1868 (CDOOM0
Beatles Anthology 1 - Disc 1 Rock 1955 | CDO0Z0.1
Beatlez Anthology 1 - Disc 2 Rock 1855 | CDO020.2
Beatles Help! Rock and Rell 1965 |COO0IZ  |w)
ram B
Tracks volumes |‘l.'dume Contents I Piay‘iist] CcD P!ayerl
Compact Digc [47:.12) [D24430] Flaglist total = 1.16:25 Yolumes: 202 / 644

On startup, volumes in this view will appear sorted from left to right (i.e. the leftmost column is the
primary sort key). To change the sort ordering, click on the corresponding column header, or make a
selection via the Sorting menu. As with the Tracks View, sorting is based on the most recent set of
columns selected for sorting, with precedence given to the most recently selected columns.

To quickly reset sorting precedence based on current column ordering, click the % button (sort
across).

Volume Filtering (and Locating Volumes)
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The set of volumes listed here depends in part on the filtering controls you have set in the Tracks
View. Volume filtering logic is based on a combination of volume attributes and track attributes:

¢ Volume attributes apply to the volume as a whole: media format, volume artist and title, notes, etc.
— in other words, things you can enter via the Add New Volumedialog.

e Track attributes apply to individual tracks, not the volume as a whole. However, it's often useful to
list only those volumes containing tracks with some particular set of attributes; for example, volumes
containing anything by Jethro Tull (even if just one song).

Filters in the Volumes view generally behave and can be used just like the filters in the Tracks view.
The available volume-specific filtering controls are summarized as follows:

Media Format Use this to view only those volumes of a particular media format.

Index Use this to view only those volumes with a specific index number, or range of index
numbers.

Category Use this to view a particular volume category or subset of categories.

Artist Use this to view a particular volume artist or subset of artist names.
Title Use this to view a particular volume title or subset of titles.

Notes Use this to view volumes based on the content of their notes.

Year Use this to view a particular volume year or range of years.

The ﬁ toolbar button, if enabled, indicates that the listed set of volumes is being constrained by one
or more track-specific filtering attributes. Clicking this button will remove all track-specific filtering in
one step, without having to switch views. (The button is not enabled unless one or more volumes is
being filtered out solely due to track filtering.)

Note: In addition to the filter controls described above, you can use column sorting to quickly identify
volumes based on other volume attributes, such as Vol Time.

Navigating the List

You can scroll through the list of volumes as you would with any standard Windows listbox. If you click
on a particular volume (or use the up- or down-arrow keys to do the same thing), it becomes
highlighted, as shown above, and the media format for that volume is displayed on the status bar at
the bottom left.

The right-hand section of the status bar indicates the number of volumes in the list, and the total
number of volumes in the library. In the example shown, no filters have been applied, so the list
contains all 512 of the library's volumes.

If you double-click on a selected volume, VisiTrax will switch to the corresponding Volume Contents
View so you can view its tracks.

Also in the example, note that the highlighted volume happens to contain a checkmark, indicating that
one or more tracks have been entered into a playlist, in the current session. Since there is an active
playlist, the Playlist view tab is shown, and the middle status bar section indicates the total playlist
time.

To access details for a selected volume (i.e. the volume as a whole, not its tracks), press the space
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bar, or choose Update Details from the Edit or right-click menu.

Additional Data Columns

The Volumes view includes many additional data columns that you don't normally see. To access
these additional columns, simply scroll to the right using the horizontal scroll bar at the bottom of the
listing. These additional columns are always available, and you are free to move any columns in or out
of the main set. For more information on how to do this, see Changing Which Columns You See.

Note that some columns contain data for which there are no manual data entry fields, either because
the data is automatically computed (e.g. Disc ID and Vol Time), or because it's simply an alternate
representation (e.g. Location).

Shortcuts:

o While in the listing, typing the first part of the volume's artist name or title will scroll the list to the first
matching entry (depending on current column sort precedence). A one-second pause in typing starts
a new sequence.

e Function key F2 (also Enter) returns focus to the list.

e Function key F3 will clear all filters.

¢ Function key F4 will activate a filter field's menu (as applicable).

e Function keys F5 - F11 provide shortcuts to each of the filter fields.

Playing MP3 and other Audio Files

If the currently highlighted volume contains one or more tracks linked to MP3 or other audio files,
clicking the ﬂ toolbar button will do one of two things:

o If Winamp V5 is installed on your PC, all of the audio file tracks in the highlighted volume will be
added to Winamp's playlist, and played.

¢ Otherwise, the first audio file track will be played by the associated media player program (if any).

Volume Index Resequencing

On occasion you may wish to resequence some of your volume index numbers. To do this, apply
appropriate filters to list only those volumes whose index numbers you wish to resequence, apply the
desired sort order, then select Re-index Volumes from the Edit menu.

Example: To resequence Compact Discs in the range CD8000-8999, select Compact Disc (or
equivalent) in the Media Format filter field, and enter 8000-999 in the Index filter field. Next, ensure
the volumes are listed in the order you want, then select Edit > Re-index Volumes.

See also: View Options and Customization
Copying to the Clipboard
Adding a New Volume
Updating a Volume
Delete and Undelete
Cross-References
Printing and Print Preview
Tracks View
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2.4 Volume Contents View

The Volume Contents View lists tall of the tracks contained in a selected volume, as shown below.
This is the view you would use for adding, deleting, or updating track entries. Tracks in this view are
sorted primarily by index number.

VisiTrax Lite - C:\Synapsa Productions'\VisiTrax\Music.trx I:___]@
File Edit View Extras Help
i b L i =k = - -
b & & B G BNCEY & arr | &4
B-52's: Cosmic Thing
No. | Track Title | Category | bpm | Time | Intro | Year |
1. Cosmic Thing Rock v 102 3:50 1889
2. Dry Country Rock 116 4:54 34 1585
3. Deadbeat Club Rock 126 4:45 27 1885
4. Love Shack Pop 134 521 07 15859
5. Junebug Rock 83 5:04 58 1589
5. Hoam Rock v 134 454 21 1989 :
7. Bushfire Rock 150 4:58 23 1885
8. Channel Z Rock 132 4:45 18 1989
9. Topaz Rock 120 4:20 04 1585
10. Follow our Blizs Instrumental 100 408 408 1989
< >
Tracks | Volumes Volume Contents | Playlist | CD Player
Rack Playlist total = 1:16:25 |CDO006 - Compact Disc [47:12) [D24430]

Navigating the List

You can scroll through the list of tracks as you would with any standard Windows listbox. If you click on
a particular track (or use the up- or down-arrow keys to do the same thing), it becomes highlighted, as
shown above, and the category for that track is displayed on the status bar at the bottom left.

The right-hand section of the status bar indicates the current volume's location index, as well as its
media format.

If you double-click on a selected volume, VisiTrax will switch to the Tracks View, automatically scolling
as necessary to the selected track.

A checkmark symbol denotes a track that has been selected into the current playlist. Since there is an
active playlist, the Playlist view tab is shown, and the middle status bar section indicates the total
playlist time.

To access details for a selected track, press the space bar, or choose Update Details from the Edit or
right-click menu. (Note that this function is not available for any tracks selected into the current

playlist.)

Additional Data Columns

The Volume Contents view includes many additional data columns that you don't normally see. To
access these additional columns, simply scroll to the right using the horizontal scroll bar at the bottom
of the listing. These additional columns are always available, and you are free to move any columns in
or out of the main set. For more information on how to do this, see Changing Which Columns You
See.

Note that some columns contain data for which there are no manual data entry fields, either because
the data is automatically computed (e.g. Disc ID and Vol Time), or because it's simply an alternate
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2.5

data representation (e.g. Location). Once such column worth noting here is Alt Source, which
appears only in this view. This is useful when organizing audio file links.

Playing MP3 and other Audio Files

If the currently highlighted track is linked to an MP3 or other audio file, clicking the ﬂ toolbar button
will initiate play of that file — either by Winamp, if you have Winamp v5 installed on your PC, or
otherwise by the file's associated media player program (if any).

Renumbering Tracks

To automatically number or renumber all the tracks sequentially, choose Renumber Tracks >
Number sequentially from the Edit menu. (Identically numbered tracks with a letter suffix, or with
identical titles and times, will remain identically numbered.)

To remove all track numbering, choose Renumber Tracks > Alphabetize with no numbering from
the Edit menu.

Volume-to-Volume Browsing

To browse from one volume's contents to those of the previous or next volume, click the <m or =
toolbar button. Volume sequencing will automatically wrap around from the last volume back to the
first, and vice versa, sounding an "OK" tone when a limit wrap occurs.

See also: View Options and Customization
Copying to the Clipboard
Adding New Tracks
Updating a Track
Delete and Undelete
Printing and Print Preview
Printing CD Labels
Volumes View

Playlists

To create a playlist, just tag the tracks you want from either the Tracks View or Volume Contents
View. You can tag (or add) any currently-highlighted track by doing any of the following...

e Press the "+" (plus) key.
¢ Right-click and select Add to Playlist from the pop-up menu.
o Easiest yet, swipe to the right on the currently-highlighted track line.

Each time you add a track to the playlist, a checkmark will be added on that line (up to a maximum of 3
checkmarks are shown per track), and a checkmark is also placed on the corresponding volume's line
(so you know that one or more of its tracks are in the playlist).

You also can add an entire volume's tracks to the playlist, in a single operation, when in the Volumes
view. Simply highlight the volume you want, then select Add to Playlist from the right-click menu.

To remove a track from the playlist, do any of the following...

e Press the "-" (minus) key.
¢ Right-click and select Remove from Playlist from the pop-up menu.

e Swipe to the left on the currently-highlighted track line.
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2.6

Checkmarks are removed accordingly.

17

Note that a track or volume cannot be deleted from the library if it's currently included in the playlist.

This limitation also applies to track modifications.

Playlist View

The Playlist view lists the contents of the current playlist, ordered by relative start time, as in this

example:

133 VisiTrax Lite - C:\Synapsa Productions\VisiTrax\Music.trx

S[=x]

File Edit View Extras Help

b el B RS vE a4

[y 1Fd
= Eix

An Example Playlist (type in your own title here!)

Start | Location | Track Title | Artist | bpm | Time | vear [a]
1 :00 | CDO230-2 Waiting for the Sun Doors 358 1970 |
T 358 CDO247-7 Der Kemmizsar Adfter the Fire 543 1983
T 541 |CDOOTE Purple Haze Hendrix, Jimi 245 15987
T 12:27 CDO004-4 Standing on Higher Gr... | Alan Parsens Pro... 5:02| 1587
5| 47:29 |cD000E-1 Cosmic Thing B-52's 102 3:50( 1989
6. 21:19 CDO00S-6 Roam B-52's 134 454 1989
7. 26813 CD0021.2-2 |Yer Blues Beatles 401 1968
8| 3014 [cD0219-8 Changes Black Sabbath 4:41| 1972
T 34:55 CDO0253-4 Zombie Cranberries 5:06| 1994
[10.] <0:01 [cDO037-2  White Room Cream 458 | 1968 [w]
) 2

Gaptime: | 0O i‘ Mominal duration: ﬁ Remove aé'EIear List

Move i‘

Traclts] ‘l.-'dumesJ Volume Contents  pilaylist | CD Player

Rock [:21]. 134 bpm Flaylist total = 1:16:25 |Tracks: 17

Each track's location index is listed as shown for quick manual access, along with its relative start

time. The first entry always has a start time of ":00".

You can add (i.e. duplicate) or remove tracks in this view the same way you can elsewhere (see

Playlists). The Remove button also will remove the currently highlighted track, and the Clear List

button will clear the entire playlist.

Any duplicate track will be annotated with one or more "replay" arrows in the rightmost variable-width
column (the Artist column in this example), with the status bar showing the scheduled time interval

since the previous play of that track, as shown here:

18 |

||

£ 1l

Gap time:l 1] il Maminal duration: I 3:!] Remaove gf Clear List

(2]

Move ﬂ

Tracks I Yolumes I Yolume Contents  Playlist I CD Player I

Rock [1:72:01 zince previous]

|F'Ia_l,l|ist total = 1:20:49 | Tracks: 18 4

You can rearrange tracks in your playlist by:

e dragging rows up or down by their leftmost "button” cells,
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e clicking on the Move arrows, or
¢ holding down the Alt key and pressing the up-arrow or down-arrow key.

You can use the Gap time field to set the estimated nominal gap time in seconds between playlist
tracks, so that (for example) the total time scheduled can include a two-second gap between tracks.

Shortcut: Pressing a digit key will change the gap time accordingly, from anywhere in this view except
in the heading area.

The Nominal duration field is useful when scheduling a program of a specific duration. If you enter
the nominal program duration into this field, the status bar will display Playlist remaining time instead
of Playlist total time. For example, enter "2:00" for a two-hour program (you could also enter "120"
minutes, which would be converted automatically to "2:00"). If the total playlist time exceeds the
nominal duration, the status bar will display the excess time as Playlist OVERTIME.

Additional Data Columns

The Playlist view includes many additional data columns that you don't normally see. To access these
additional columns, simply scroll to the right using the horizontal scroll bar at the bottom of the listing.
These additional columns are always available, and you are free to move any columns in or out of the
main set. For more information on how to do this, see Changing Which Columns You See.

Changing the Playlist Title

You can customize the title that appears at the top of the Playlist view, and on printed playlists, by
typing directly into the heading field above the playlist grid. You can also change the font and coloring
of the displayed title via the right-click menu.

Saving and Recalling Playlists

To save a playlist for later use, select Save Playlist... from the File menu. The complete playlist,
including the title, will be saved to the .vxp file you specify.

To recall a previously-saved playlist, select Recall Playlist... from the File menu.

Playing MP3 and other Audio Files

The two toolbar buttons shown below are used for playing MP3 or other audio files:

ﬂ If the currently highlighted track is linked to an MP3 or other audio file, clicking this button will
initiate play of that file — either by Winamp v5 (if installed), or by the file's associated media
player program (if applicable)

@ This button will appear only if Winamp v5 is installed on your PC, and applies only to the
Playlist view. If any listed tracks are linked to audio files, clicking on this button will add those
files to Winamp's playlist, and Winamp will begin playing them (if it's not already playing
something). Duplicate tracks preceding the new set will be removed from Winamp's current
playlist.

Converting a Playlist into a New Volume

One use for playlists is for to facilitate recording custom tapes or CDs, which themselves may need to
be entered into your library as new volumes. To quickly convert a playlist into a volume, ensure that the
listed tracks are ordered the way they were recorded, then select Convert Playlist to Volume... from
either the Edit menu or the right-click pop-up menu. At this point you will be presented with a Convert
Playlist to New Volume dialog, which is used just like Adding a New Volume, except that the current

Copyright 1999-2023 Synapsa Productions



Using VisiTrax 19

playlist's tracks will be included automatically, numbered in sequence.

See also: View Options and Customization
Copying to the Clipboard
Printing and Print Preview
Printing CD Labels

2.7 CD Player View

With the CD Player view, you can audition Compact Discs (CDs), conveniently acquire a CD's nhame
and track titles via an Internet-based gnudb CD data server, and quickly import this information into
your VisiTrax library by clicking the Add button; this changes to an Update button once the data is in
your library. (Track times are read directly from the CD.)

The CD Player view provides two slightly different views for CD track information, depending on
whether the CD is by a single artist or group (first example below), or by various artists (second
example), as set by the List Artists checkbox control:

VisiTrax - N:\Synapsa Productions\VisiTrax\WMusic.trx [;]@
File Wiew ©CD Extras Help

EN=AENFERE AR RGIN A= R | e
v Connect to: Ius.freedb.org [San Joze, CA 1154A] ;Il E -mail: Isuppnrt@synapsa.com _
SOUICE: IHemote data VIl Remate title: IScorpinns / Bad For Good: The Very Best of Sco;l =3 Submit CO Data |

CD Title: IBad For Good: The Wery Best of Scorpiong ol
CD Adrtist: IScnrpions
Categony: IHock LI Genre: I ear I
Mo. Track Title | Tirmne | ”~ Track Motes
1. |Rock ou Like a Hurricare 412 | =
|2 |Loving You Sunday Marning A6
3| The Zan 5:28
4 |MoOne Like You 356
|5 | Blackout 347
B | SHill Lowing Yo 4:43
7| Big City Mights 4:08
n Bjievi in i:uve 404 [v] [ Listartists = Swap artists & titles

l_lellilﬁl. & Update | ‘? Help

Tlacksl \»"nlumesl VYolume Enntentsl Playlist CD Player |
Total CD time = 79:53 A

Example Single Artist CD View
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VisiTrax - N:\Synapsa Productions\VisiTrax\Music.trx g@
File Views CD Extras Help

e & B BB E Y [
v Connect to: Ius.freedb.org [San Jogze, Ca USA) ;Il E-mail: Isuppnlt@synapsa.com _
Source: IHemote data v” Remate tithe: IVarinus Atizts o Classic '60s: Blowin' vour Mind ;I =3 Submit CO Data |

CD Mates
Time-Life Music

CD Title: ICIassic ‘B0z Blowin' vour Mind

CD Artigt: I\-"alious Artists

Cateqary: IHock ;I Genre: IFlock Year |1 933

Mo Track Title | Time | Track Artist I.A. Track Motes

1. |Five 0'Clock word 210 The Vogues =l

2 |Fed Rubber Ball 219 The Cyrkle

2. | Sunshine Superman 324 Donovan

4 |Kicks 2:24 Paul Revere and the Raiders

5. |Hang On Sloopy 304 The McCoyps

|_E.|Mr. Tambouring Man 219 The Bwrds

7. |Everyday Pecple 223 Sly and the Family Stone i | . ) . .
8| Time Haz Come Today 4:54 | The Chambers Brothers || IV Listariste [ Swap artists & tiles

Jh»|H N oo ool o Updatz | 2 Hep

Tlacksl Vulumesl Yolume Euntentsl Playlist CD Player |

Total CD time = 37:16 &
Example Various Artists CD View

If you have more than one CD-ROM drive, a drive selection drop-down list control (not shown above)
will appear to the left of the player buttons. VisiTrax will remember the drive you select between
sessions.

To have VisiTrax automatically detect CDs and activate the CD Player view whenever you insert a CD,
select Auto-detect CDs from the View > Options menu. Auto-detection will commence the first time
you enter the CD Player view in a given session.

Note: Some "Media Player" or "CD Player" programs might use a CD-ROM drive in an
exclusive, non-shared mode. If one of these is running in this mode, no other CD player
program will be able to access the drive. If the offending program has a configuration setting
option for using the CD-ROM drive in shared mode, try that setting. Otherwise, you will need
to stop the other player before the VisiTrax CD player can start up or begin to detect CDs.

Each time a CD is inserted, VisiTrax will try to find the CD's information in the following lookup
sequence:

o First, VisiTrax will look for an entry in your VisiTrax library database.

e Next, VisiTrax will look for an entry in your PC's CDPLAYER.INI file — a data file that is commonly
used by various CD player programs. (If it exists, this file will be in your Windows root directory.)

¢ Finally, if you have enabled an on-line connection to a gnudb remote data server, VisiTrax will look
for one or more matching entries from the server.

Once the lookup has completed, the Source box will indicate one of the following data sources:
Visitrax library

cdplayer.ini
Remote data
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The CD information displayed will be from the indicated data source. To view information from one of
the other data sources, simply choose the source you want from the Source drop-down menu.

Usually, the initial source shown will probably be what you want. For example, if a given CD's data can
be found in both the VisiTrax library and CDPLAYER.INI, the Source box will indicate VisiTrax library,
as that would probably be the source you'd want to use. But if data were only available in your
CDPLAYER.INI file, the Source box in that case would indicate cdplayer.ini.

When the data source is Remote data, another selection box — Remote title — comes into play. This
box will always contain at least one menu option: None (new CD entry). If one or more matching
entries are found from the remote data server, the drop-down menu for this box will also list a title for
each entry found. If you choose one of these titles, VisiTrax will download the corresponding remote
record and display its contents in the various CD information data fields.

Note: The CD player's Category box is intended primarily for use with remote data server
functions, and will be disabled unless a remote data server has been accessed. It should be
noted also that, although the Category box's drop-down menu will be limited to the set of
category names downloaded from the remote data server, this constraint exists only within
the CD Player view, and you are always free to use any category names you wish in your
VisiTrax library database proper.

Playing CD Tracks

To begin playing a CD track, do any of the following:

¢ Click on the Ll button.

¢ Click on one of the track number cells in the column.
e Select a track title and press Enter.

¢ Select Play from the CD menu.

Editing CD Information

To edit CD information, click or tab into each field and edit as necessary. You can edit information for
any track, regardless of any track being played. Changes can be saved in any of the following ways:

¢ To save changes to your computer's shared CDPLAYER.INI file, select Write to CDPLAYER.INI
from the CD menu.

¢ To save changes to your VisiTrax library database, click on the Add / Update button (this also
updates CDPLAYER.INI).

¢ To save changes to gnudb, click on the Submit CD Data button (also see Submitting CD Data,
below).

Track Titles and Subtitles

When a CD's track titles are filled in from your VisiTrax library database, and a given database track
record contains a subtitle, a composite title will be displayed, consisting of both the title and subtitle
separated by a colon; for example (colors for illustration only):

Symphony No. 6 ("Pastoral™), Op. 68: I. Allegro ma non troppo

Conversely, when you Add or Update a CD's data to your VisiTrax database from this view, subtitles
will be split out from the title — provided the following conditions are all true:

o the title contains two parts separated by a colon followed by a space;
¢ an adjacent title also contains two parts; and
o the first part is identical in both adjacent titles.

Copyright 1999-2023 Synapsa Productions



22

VisiTrax Online Help

The reason for the above constraint is to reduce the chances of a "false hit", where a colon may
appear as part of a title for reasons other than to denote a subtitle.

Using gnudb

To begin using gnudb, be sure you have an established Internet connection, then click on the Connect
to checkbox. As long as this checkbox is activated, on-line data lookups are initiated automatically for
each CD inserted. (If you have an always-on Internet connection, you may wish to select Auto-
connect to Server from the View > Options menu.)

Note: VisiTrax uses your web browser's settings to determine whether you use dial-up
networking and/or a proxy server. If you use dial-up networking, you'll need to establish a
dial-up connection before performing this operation.

The gnudb servers receive submittals from thousands of users all over the world, so you can expect
to find errors on occasion. Once a CD's information has been acquired, look over the information for
typographical errors or other inconsistencies. VisiTrax lets you correct or modify this information at
several stages:

e The first stage is in the CD Player view itself. This is most useful when you see errors in gnudb's
data: simply correct the data in this view, submit the corrections back to the CD data server for
posterity, then click on the Add button to import the data into your VisiTrax library.

e The second stage is in the Add New CD dialog that appears after clicking on Add in the CD Player
view. While the gnudb community tends to list artists using the form "John Smith", or "The Beach
Boys", you might prefer the catalog index format, such as "Smith, John" or "Beatles, The" (or just
"Beatles"). You could do this in the CD Player dialog, of course, but you wouldn't necessarily submit
such changes back to gnudb. Using the Add New CD dialog for this purpose also lets you take
advantage of the dialog's "smart data entry" features. (Don't forget to assign a CD index here while
you're at it.)

e Once you click the Add button in the Add New CD dialog, the CD's individual track records will also
be added, automatically. Editing these individual track entries would comprise the third, track-level
stage. One of the things you might want to do here is adjust the Category for each track, and
perhaps enter or change other information, such as the release year.

Note: Once a CD has been added to your library, the Add button will be replaced with an
Update button.

Hint: To quickly shift names around in an artist field, or shift words around in a title field, simply
double click on that field. For example, this could be used to change "John Smith" to "Smith,
John", or vice versa.

Track Artists and gnudb

Due to some laxity in the original CDDB protocol specification, gnudb's database is somewhat
inconsistent with respect to track artist information for compilation CDs with multiple artists.
Commonly-seen variations within the data include:

o track titles of the form "artist / title" or "title / artist"
e track titles of the form "title - artist" or "artist - title"
o track titles of the form "title (artist)" or "artist (title)"
e track titles of the form "title; artist" or "artist; title"

e artist entered in the "extra track information" field
¢ no track artists specified at all

The most recent protocol, as published by gnudb.org, now states a preference for the "artist / title"
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convention, with a space on either side of the "/". Thus, VisiTrax looks for track artists using the
following order of precedence:

1. All track titles contain a /" splitter [artist / title is assumed]

2. All tracks contain a single line of Extra data [thus probably track artists]
3. All track titles contain a "-" splitter [typically title - artist]

4. All track titles contain parentheses [typically title (artist)]

5. All track titles contain a ";" splitter [typically title; artist]

If VisiTrax detects what appear to be track artists, it will automatically attempt to separate the artist and
title information, displaying the Track Artist column. You can manually show or hide this column via
the List Artists checkbox control.

If it appears likely that the artist and title obtained from the CD data server might have been
transposed, VisiTrax will display a warning message. The Swap Artists & Titles checkbox can be
used to swap the contents of the Track Title and Track Artist columns.

What if my CD isn't found on gnudb?

If you're working with a custom CD of your own, or with a published CD that just doesn't happen to be
listed (yet) at gnudb, your main objective will be to add its data to your VisiTrax library database, or to
CDPLAYERL.INI, or to both. If the data is not available in either place (you can check this using the
Source box drop-down menu options), simply fill in the data for the CD as needed. Once all of the
essential information has been filled in ("Notes" fields can be left empty if desired), click the Add
button to add the CD to your VisiTrax database, as described above. You can also click the Add
button without filling in any data, in which case VisiTrax will ask if you want to use the Add New CD
dialog; this option gives you access to some smart data-entry features not available in the CD Player
view, so you may prefer this alternate data entry approach.

In some situations (depending in part on other programs you might also be using), you might find your
CD's data (or much of it) is already available from CDPLAYER.INLI. If that's the case, you'll only need to
add or modify data as needed, rather than having to enter everything from scratch.

If you're working with a published CD that was not listed on the gnudb server, see also Submitting CD
Data, below.

Updating an Existing CD Volume Entry

Once a CD has been added to your library, the Add button will be replaced with an Update button.
Clicking Update will update the existing CD volume entry, and its corresponding track entries, using
the data that appears in the CD Player view. This can be handy, for example, if you happen to catch a
spelling error in one of the titles while in this view. (Note that Update will not disturb existing
information not ordinarily seen in this view, such as volume locator index, or track category, year, lead-
in time, etc.)

What if | already entered my CD as a "New Volume"?

Each compact disc has a (relatively) unique media identifier code and CDDB-style disc identifier code.
VisiTrax uses these numeric codes to associate a physical compact disc with its corresponding
volume database record. Normally, this association takes place automatically when you click on the
Add button from the CD Player view. However, the Add New Volume and Volume Details dialogs also
let you perfom (or change) this association.

Submitting CD Data

The gnudb service is likely to find entries for most of your CDs. If your CD is not found (and it's a
published CD, not some custom job) you can enter its data and submit it to the server via the Submit
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CD Data button. You can also submit corrections to existing entries. Before you begin making
submittals, though, look at a reasonable number of examples of existing CD entries, so you can
become somewhat familiar with common practice (or at least preferred practice):

o Titles, artist names, etc., should use standard capitalization rules for mixed-case titles.

o If the CD contains tracks from various artists, the CD's Artist field should be "Various Artists", or
something equivalent.

¢ Titles and artist names should be of reasonable length.

o Careful spelling and punctuation is generally appreciated.

¢ "Special" characters beyond those used for ordinary narrative text, should be avoided.

¢ Avoid using the slash character ("/") in the title and artist edit fields.

CD data submittals require an e-mail reply address, so that you can be notified if there's a problem.
Enter your e-mail reply address in the E-Mail field.

The Submit CD Data button action will be inhibited unless a certain set of minimal conditions have
been met. This reduces the likelihood of accidentally sending an incomplete or useless submittal.
Conditions include an e-mail address, no empty fields that shouldn't be empty, and (in the case of
changes) some difference versus the original data record.

Naturally, it makes no sense to submit a new CD without first confirming that it is, in fact, a new CD as
far as gnudb is concerned, and VisiTrax performs several checks to ensure this has happened. The
selected option in the Remote title box will establish whether the submittal will be a revision against an
existing CD title, or a submittal for a new CD entry. The Submit CD Data button's pop-up hint will
indicate the revision level of the submission; new CD entries are always submitted as revision 0, while
revised submittals will always be submitted with a revision number one greater than that of the original
data record most recently downloaded.

Resolving CD Player or CD Server Performance Issues

VisiTrax accesses gnudb's CD data servers just like a web browser. Occasionally, you might
encounter an error message or other performance problem while accessing a server. Unless the error
message indicates something specific in this regard, usually the best course of action is to try the
access at least one or two more times before concluding that there's a problem of any significance.

If errors tend to occur frequently, or if server accesses appear to be too slow, try choosing a
different site via the Connect to drop-down list. (Sometimes the fastest-responding server is not the
geographically closest one.)

To re-acquire the list of CD data server sites, click inside the Connect to editing box and press the
Enter key. The list of servers will be (re-)acquired from the site shown. To specify a different CD
data server, choose it from the drop-down list, or type in its address (if this field is blank, the original
standard address will be restored).

To re-establish communications with a specific server, choose it from the Connect to drop-down
list. This also forces a fresh CD title query if you have a CD inserted.

To repeat a CD title query from the current server, either re-choose the server from the Connect to
drop-down list, or choose Refresh from the CD menu.

To re-read a specific CD's track information for a given CD title, re-choose the CD title from the
Remote title drop-down list.

To force a re-read of data from the CD, choose Refresh (read CD again) from the CD menu, or
press Ctrl-F5.
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If you continue to encounter problems with gnudb using VisiTrax, please send us an e-mail message
with as much relevant detail as possible.

See also: Installation and Configuration
View Options and Customization

2.7.1 What is gnudb?

The gnudb.org family of free database servers provides CD information via the internet. The common
gnudb database contains artist, disc title, track titles, and other information for digital audio compact
discs. Over time, this archive has grown to contain a substantial collection of CD information (over
700,000 album titles) and continues to grow at a rapid rate.

The VisiTrax CD Player accesses the gnudb servers using HTTP (the same text-based protocol used
by web browsers) as an outer layer, and within that, the standard "CDDB" (CD database) protocol used
by gnudb.org.

2.8  Working with MP3 and Other Audio Files

In a VisiTrax music library database, each track can optionally be linked to a corresponding audio file
(such as MP3). When combined with Winamp (v5 or v2.9), this lets you do the following things:

e Import Winamp playlists into VisiTrax as new volumes

e Propagate audio file links to other identically-named tracks

e Update and consolidate audio file links

e Schedule and initiate play of individual audio files, or sets of audio files, from VisiTrax

Winamp is a freeware player for MP3 and other audio files. It is available for download at
https://www.winamp.com. Winamp supports a large number of third-party plug-ins that add to its basic

capabilities. VisiTrax complements Winamp with its ability to organize all your music media in one
place, and with its powerful, filter-based music search capability.

Importing a Winamp Playlist

A Winamp playlist can be imported as a new VisiTrax volume. To do this:

e Using Winamp, create the playlist you wish to have imported.
e Leave Winamp running and switch to VisiTrax.
e From the VisiTrax Edit menu, choose New Volume...

e Within the Add New Volume dialog that appears, fill in the basic details for the new volume. For
Media Format, enter something suitable, such as "Audio Files".

e Click the Import Winamp Playlist checkbox control at the bottom of the dialog (so that it is
checked), then click Add.

If the playlist to be imported contains one or more duplicates of tracks already in your library database,
VisiTrax will ask if you want to skip the duplicates. ("Duplicates" in this sense means tracks referring to
the same audio file path.)

Propagating Audio File Links

To propagate audio file links from tracks already linked to audio files, to like-named tracks in the same
library database, do this:
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¢ In the Tracks view, select the set of tracks to which you want audio file links added (remove all
filters if you want this done to all tracks possible). Alternatively, if you wish to limit this to a specific
volume, go to the Volume Contents view for that volume.

e From the Edit menu, choose Update Audio File Links.

Link propagation will be limited to tracks with identical titles and artist names, and with reasonably
similar playing times.

Updating Links to Moved Audio Files

If your linked-to audio files are spread among two or more directories, and you move some of the files
from one such directory to another, the Update Audio File Links function described above will also
update the file path information for your audio file links. It does this by checking whether each linked
file's path is valid, and if not, it then looks for the same named file within those directories used by
other linked-to audio files.

Removing Redundant Audio File Tracks

You may find that, after propagating audio file links from an imported Winamp playlist volume to other
tracks in your database, there is no longer any reason to keep the imported audio file tracks around.
For example, perhaps you have generated MP3 files from a CD in your library database, then imported
the MP3 tracks from Winamp back into VisiTrax. You now have two entries for each track (the original
CD track, and its MP3 copy). Or perhaps you have done this for 100 CDs (whew!).

Before removing the tracks you believe to be redundant, it would help to confirm that their links links
did indeed propagate successfully to other tracks. This can be done by looking at the imported
volume's contents with the Volume Contents view, and examining the Alt Source column (this is an
"extra" column you'll probably need to bring into view). If a selected track's audio file link is also linked
to from some other track in your library, this will appear in the Alt Source column for that track. If Alt
Source is blank for a selected track, then its audio file link (if any) has not been propagated. (Again,
automatic link propagation relies on identical titles and artist names, as well as closely matching
playing times.)

Hint: To identify tracks that have audio file links, view the File Name column.

Playing Selected Audio File Tracks (or Volumes)

To initiate play for any selected track that contains an audio file link (or if in the Volumes view, for a
selected volume's tracks), do any of the following:

¢ click the ﬂ toolbar button; or
e choose Play Selected Track or Volume from the right-click menu; or

e press the "." (period or full-stop) key.

If Winamp v5 (or v2.9) is installed, this will add the track (or the volume's tracks) to Winamp's playlist,
and initiate play if not already playing. If Winamp is not installed, this will initiate play of a single track if
a suitable player program has been associated with the audio file's type.

Playing all the Audio Files in a Playlist

VisiTrax's playlist capability can be used to very good advantage in conjunction with Winamp. You can
create any number of saved playlists of tracks that are linked to audio files. When in the Playlist view,
you can transfer its current playlist to Winamp's playlist by doing either of the following:

e click the @ toolbar button; or
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e choose Play All Audio Files in Playlist from the right-click menu.

This will append your playlist's files to Winamp's playlist, in the exact sequence listed, and Winamp will
begin playing them (if it's not already playing something). Duplicate tracks preceding the new set (other
than the currently playing track) will be removed from Winamp's current playlist, but other tracks will
remain in Winamp's playing queue.

Special File Path Considerations

To successfully queue audio files to Winamp or another player program, VisiTrax must retain complete
pathnames in its own links to those files. This can be an important consideration in a few situations:

1. To use a shared VisiTrax library to link to shared audio files within a local network, establish a
common shared folder for the audio files, and use a common linkage name for that folder that all
the PCs on that network will understand. One way to do this is to assign a drive letter to the
shared folder, and assign that same drive letter mapping on each PC. A possibly better
alternative is to use UNC naming (e.g. "\\office\Shared Audio"); the advantage of this latter
approach is that drive letter mapping doesn't need to be set up on each PC. [Windows 2000 and
Windows XP support UNC naming.]

2. If you migrate to a new PC and the audio files end up in a different path than before, the audio
file links in your VisiTrax library will need to be updated to reflect this. Performing this update is
not necessarily a tedious thing to do: for example, you could temporarily export your library to a
text file, edit the text file and then re-import the data; alternatively, you also could use the Update
Audio File Links feature to advantage.

3. For audio files located anywhere under the VisiTrax program's own folder (the one containing
VisiTrax.exe), VisiTrax records the links using relative rather than absolute path names when
writing to a .TRX library file. Then, whenever that .TRX library file is opened again, the absolute
path names are reconstituted based on the location from which VisiTrax starts. [This provides yet
another network sharing alternative: you could locate all the audio files under a shared folder
containing VisiTrax.exe, and have all the PCs run VisiTrax from that single location; on each PC,
the audio file links would then be based on the path of the VisiTrax executable.]

2.9 Creating a New Library

To create a new library database file from scratch, select New Library from the File menu (or click on
the E toolbar button).

If another library file was already open and you made any changes, you'll be asked if you wish to save
it, and then that file will be closed.

A newly-created library database contains no predefined media format types or track categories, since
it contains no volumes or tracks. To add new volumes and their tracks to your library:

e You can add pre-recorded CDs via the Add button on the CD Player view.

¢ You can manually type in each new volume and its tracks via the Add New Volume dialog.

e You can convert a playlist you've created from one or more existing volumes, to a new volume.
This can be handy when you're creating a new custom CD or tape.

See Opening an Existing Library
also:

2.10 Opening an Existing Library

To open an existing library database file, select Open... from the File menu (or click on the E toolbar
button).
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If another library file was already open and you made any changes, you'll be asked if you wish to save

it, and then that file will be closed.

To help you get familiarized with VisiTrax, we've provided an example library you can experiment with.
Just open Example.trx, which you should find in your VisiTrax installation directory.

See
also:

Creating a New Library

Adding a New Volume

To add a new volume to your library database, select New Volume from the Edit menu, or press
Ctrl-N. (In the Volumes view, you can press Insert to do the same thing.) This will present a dialog box

similar to the one here:

[ Add New Volume 1

Title: |Best of the Alan Parsons Project |

rtist: |4lan Parsons Project |

Category: [Frock | Yeaufisez £

Media Format: |Compact Disc | @l Location Index: |CD0319 |

Motes: | ;|
[ Vadd | camce | 7 Hep

Similar dialogs also appear...

o after you select Convert Playlist to Volume from the Edit menu or right-click pop-up menu from
the Playlist view (title bar will read Convert Playlist to New Volume).
o after you click the Add button in the CD Player view, except in that case the dialog looks like this:

Add New CD 1

Title: |Bad for Good: The Very Best of Scorpions |

frtist: |Scorpions |

Category: [Frock =] eau[2001 £

Media Format: |Compact Disc | @l Location Index: |CD0323 |

Hotes: | |
I buofiect | o/ Add | % Cancel | ? Hep

At a minimum, the Title, Artist, and Media Format fields (also Category field in the Add New CD
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dialog) need to be completed to create a valid volume record. You can enter anything you wish for
these fields. Each of these fields also contains a drop-down list of entries you've made before.

Hint: To quickly shift names around in the Artist field, simply double click on that field. For example,
this could be used to change "John Smith" to "Smith, John", or vice versa. This feature also works
in the Title field.

In the Add New CD dialog, the contents of the Category and Year fields will be assigned to each of
the CD's track records. If the tracks have various categories or years, just enter the predominant
category and year here, then revise individual track records later on as necessary.

Just to the right of the Media Format field is a button, which can be used to associate this volume
with the currently-loaded CD, or to change or remove a CD association. Clicking on this button will
present a short menu of available options. Naturally, a given physical CD should be associated with no
more than one volume in your database. Unless you are entering custom CDs, you probably have no
need to use this button.

The two optional Notes fields support text of arbitrary length. Both fields show the same information,
but merely in different formats. The single-line Notes field lets you select from a drop-down list of all
existing volume notes entries, and also can also be useful for entering very brief notes. Typically, these
fields are used for miscellaneous information about the volume itself, including physical location or
lending information, condition, value, etc. For CDs, these fields map to the CD's Notes field in the CD

Player view.

The Location Index field is optional, but strongly encouraged, especially if you use playlists. This
provides a concise way to quickly identify each volume. If you've just entered a new media format,
assign a two-letter prefix for this field. The prefix you assign here will be applied to all volumes of that
same media format. The only limitation is that the prefix can't the same as one used by another media
format.

As for the rest of the location code, you can use any number from 1 (or "0001") to 9999, as long as it
hasn't already been used for this particular media format. You might want to assign different ranges of
numbers to different genres or other discriminators; for example, you might number your CDs as
follows:

CDO0001 - 0999 Classical music CDs
CD1000 - 1999 Folk music

CD2000 - 2999 Rock music

CD3000 - 3999 Country/western music
CD4000 - 4499 Pan Flute music
CD4500 - 4999 Fred's stuff

...and so on. (Note that this is only an example — you can use number ranges any way you want, or not
at all.)

If the media format is one you've already been using, VisiTrax will fill in the location index field for you
with the first available index number. If want to assign a different index number, just change it.

If you click on the arrow on the right of this field, a drop-down list of available ranges will appear. For
example, let's say you've already entered five CD volumes under each of the above example ranges;
i.e. 1-5, 1000-1004, 2000-2006, 3000-3004, 4000-4004, and 4500-4504. In that case, the following
available ranges would be listed (in this example we're using only whole-numbered locator index
values in our library):

CDO0006 - 0999
CD1005 - 1999
CD2005 - 2999
CD3005 - 3999
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CD4005 - 4499
CDA4505 - 4999
CD5000 - 9999

Initially, the data field in this example would contain CD0006. Let's say you just bought another Zamfir
and His Pan Flute CD, so to select the next available Pan Flute music index, you could pick the fifth

entry from the list (CD4005 - 4499). The first index in this range, CD4005, would be transferred to the
data field for you.

If the Add New CD dialog's Auto-Eject box is checked, the CD will be ejected upon addition of the
new CD entry into the library. When this is used together with the Auto-Detect CDs option (set via the
View > Options menu), you can avoid having to manually switch back to the CD Player view for each
CD to be added.

Once the needed fields have been filled in, click the Add button to add this new volume entry to the
database and begin adding tracks. (If this was an Add New CD dialog, all of the tracks will be added
for you at this point.)

Importing a Winamp Playlist

If Winamp (v5) is currently running on your PC, and its playlist is not empty, an Import Winamp
Playlist checkbox control will appear that the bottom of the Add New Volume dialog, as shown below.
To create a new volume containing tracks imported from Winamp's playlist, put a checkmark in the
Import Winamp Playlist box before clicking Add.

I Add New Volume
Title: |ssorted Reggas |
Atist: [Various |
Category: [Freagae =] ear[200 2]
Media Format: [4udio Files | @ Location Index: |AFO003 |
Motes: | j

W Impart Winamp Playlist ’WI X Cancel | ? Hep |

If the playlist to be imported contains one or more duplicates of tracks already in your library database,
VisiTrax will ask if you want to skip the duplicates.

Note 1:If the Add button's caption is colored dark red, it means at least one data field is incomplete or
contains invalid information. Yellow data entry fields mean the same thing. More specific
information will be displayed if you click Add in this situation.

Note 2:Don't forget to save your changes periodically.

See also: Updating a Volume
Delete and Undelete
Cross-References
Creating a New Library
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Adding New Tracks

To begin adding new tracks to your library database, do either of the following:

e From the Volumes View, double-click on an existing volume entry to enter the corresponding Volume
Contents View for that volume, then press the Insert key (or select New Track from either the Edit

menu or the right-click menu).

e From any of the list views, add a new volume by selecting New Volume from either the Edit menu or
the right-click menu. Adding a new volume entry automatically leads into adding its track entries.

You will be presented with a dialog box similar to this:

123 Add New Track

Title: IE_I,Je in the Sy

Subtitle: |

Aitist: I.t’-‘n.lan Parzons Project

Composer: I

LCategon: IHDck

Lol | Led Lol Lol Lol Lo ] 69

MHates: I

File Name:l Browsze. |
Track No.. |2 ﬂiear:|1982 ﬂTimg:l £25 o[ 18 BRM[TIZ @)

o Add I x Cancel | ? Help |

At a minimum, you'll need to fill in the Title, Artist, and Category fields to create a valid track record.
You can enter anything you wish for these fields. Each of these fields also contains a drop-down list of
entries you've made before (useful primarily for category and artist).

The optional Subtitle and Composer fields can be especially useful for classical music or similarly
organized material. For example, use the Subtitle field where you have a group of tracks comprising a
single symphony (title), with each track containing a movement (subtitle). [Hint: When printing classical
music listings, you may prefer listing the Track Title field without the Subtitle field, and the Grp Time
field rather than the Time field. Grp Time is an automatically calculated total of times for all tracks
having both subtitles and identical titles; for tracks with no subtitles, it is the same as Time.]

Hint: To quickly shift names around in the Artist or Composer field, simply double click on that field.
For example, this could be used to change "John Smith" to "Smith, John", or vice versa. This
feature also works in the Title field.

The two optional Notes fields support text of arbitrary length. Both fields show the same information,
but merely in different formats. The single-line Notes field lets you select from a drop-down list of all
existing volume notes entries, and also can also be useful for entering very brief notes. Typically, these
fields are used for miscellaneous information about the track. For CDs, these fields map to the Track
Notes field in the CD Player view.

The File Name field is used to link the track record to an MP3 or other playable audio file. Click on the
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Browse button to locate the folder and file for the track of interest. (If Winamp v5 is installed on your
PC, you can use the Playlistview to play sets of tracks containing file links.)

The Index (if not left blank) can be any value from 1 to 9999, Al to A9999, B1 to B9999, or 1A-9999B.
More than one track can be assigned the same index if desired. A and B are useful for two-sided
media such as phonograph records or DVDs. The "A1" form is for media containing multiple tracks on
a side; the "1A" form is for boxes or trays of singles (e.g. 45 RPM records).

The Year field can be any valid non-zero year, or you can leave it blank. Entering "0" is equivalent to
blank, or "no year defined".

The Time field is used for the track's elapsed playing time. Any value under 10 hours (10:00:00) can
be used. As an alternative to a colon, you also can key in times using a semicolon, comma, or period
(full stop).

The Intro field is used primarily by DJs to indicate how much talk-over time is available (in seconds) at
the beginning of the track. (This is sometimes called lead-in time.)

The BPM (beats per minute) field is used primarily by DJs to optimize continuity from track to track. To
accurately determine a track's tempo, you can tap the "clock" button at the right of this field in time with
the beat of the track as you listen to it. Continue tapping the button until the value shown settles to (or
close to) a stable value, typically 8-12 taps.

Once the needed fields have been filled in, click the Add button to add this new track entry to the
current volume and begin adding the next one. Once you have no more new tracks to add, click the
Cancel button.

A couple of shortcuts:

e The "+" and "-" keys can be used to increment or decrement numeric fields.
e Typing "T" in the Year field will enter the current year ("This year").

Note 1:If the Add button's caption is colored dark red, it means at least one data field is incomplete or
contains invalid information. Yellow data entry fields mean the same thing. More specific
information will be displayed if you click Add in this situation.

Note 2:Don't forget to save your changes periodically.

See also: Updating a Track
Adding a New Volume
Delete and Undelete

Playlists

Updating a Volume

To update (or just examine) the details for an existing volume record, first select the volume of interest
in the Volumes View, then do any one of the following:

e press the Space bar, or
¢ select Update Details from the Edit menu, or
¢ select Update Details from the right-click menu.

VisiTrax will display a Volume Details dialog similar to the dialog used for adding a new volume.

A similar dialog likewise appears if you click the CD Player view's Update button.
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See also: Updating a Track
Delete and Undelete

2.14 Updating a Track

To update (or just examine) an existing track, first select the track of interest in the Volume Contents
View, then do any one of the following:

e press the Space bar, or
¢ select Update Details from the Edit menu, or
¢ select Update Details from the right-click menu.

You will be presented with a dialog box similar to the one here:

2 Track Details
Title: |Evein the Sky ~|

Subtitle: | ~|

tist: |4lan Parsons Project | dkiE
Composer. | | dkiE
Categary: |Fock | dkiE
Hotes: | | T gtk

File Name:l Browsze. |
Track No.. |2 ﬂiear:|1982 ﬂTimg:l 525l 18 BRM[TIZ @)

rm ¢ Update I x Cancel | ? Help |

Usage of this dialog is identical to that used for adding a new track, with one additional feature: several
of the data fields can be duplicated to succeeding tracks in the current volume, if the corresponding
"paper doll" checkboxes are checked. If the Artist, Category, or Year is duplicated in this fashion,
starting with the first track, the corresponding information in the volume record also is updated.

See also: Updating a Volume
Delete and Undelete

2.15 Delete and Undelete

When you're in the Volume Contents View, you can delete the currently selected track by doing any of
the following:

Select Delete from the Edit menu.
Select Delete from the right-click menu.
Press the Delete key.

When you're in the Volumes View, you can delete an entire volume in the same way.
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2.16

2.17

You can restore a track or volume that you just deleted by doing any of the following:

Select Undelete from the Edit menu.
Select Undelete from the right-click menu.
Press Ctrl-Z.

While there's no fixed limit on the number of successive undelete operations that can be done, once
the current library file has been closed, all deletions become permanent.

If you are concerned about accidental deletions, notwithstanding the undelete feature, a Confirm on
Delete configuration option is available.

Saving Your Changes

VisiTrax does not make any permanent updates to your library file until you explicitly tell it to save the
changes you've made, by doing any of the following:

« Click on the H toolbar button. If this button is grayed out, your file is up to date (no changes are
pending).

e Select Save from the File menu. If this menu option is grayed out, no changes are pending.

o If you attempt to close the current file, and the file is not up to date because you have changes
pending, VisiTrax will ask if you wish to save your changes. This occurs if you select New, Open, or
Close; or if you exit the program.

If you've just created a new library file and haven't named it yet, VisiTrax will query you for the filename
when you do any of the above actions.

To explicitly save the current library with a new filename, select Save As... from the File menu. This
can be useful for deriving a new library file from an existing one.

To reduce the risk of losing your work due to a system problem (e.g. sudden power failure), be
sure to save your changes periodically, especially after making significant additions. (And of
course it should go without saying that it's prudent to make system backups regularly.)

Each time your library file is saved, a backup of the preceding version will be saved in the same
directory. The filename will be the same, except that the first character in the file extension will be a
tilde ("~").

See also: Supported File Formats

Merging Library Files

You can merge two or more VisiTrax library files into a single library file, using either of the procedures
described below. Any number of VisiTrax library files can be merged together simply by repeating the
process.

In either of these procedures, we will assume two library files name A.TRX and B.TRX (for fastest
results, use the smaller file for B.TRX).

Merging with Copy / Paste

This easy procedure relies on the fact that the Tracks view contains every data field in the library (the
other views only contain subsets of some sort).

1) Start VisiTrax and open B.TRX.
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2) While in the Tracks view, copy the displayed tracks to the Windows clipboard by pressing Ctrl-C.
3) Now open file A TRX.

4) Next, while in the Tracks view, paste the clipboard data by pressing Ctrl-V.

5) After the data merge completes, check the results, then save.

Pressing Ctrl-C is equivalent to selecting Copy Every Column to Clipboard > Normal Text Format
from either the Edit menu or the right-click menu.

Pressing Ctrl-V is equivalent to selecting Paste from Clipboard from either the Edit menu or the
right-click menu.

Merging with a Text File

This procedure is not quite as convenient as the copy/paste method, but it does work just as well.

1) Start VisiTrax and open B.TRX.

2) Select Save As... from the File menu and save as a text file (B.TXT).

3) Now open file A TRX.

4) Next, open file B.TXT. You'll be asked if you want to merge the data; choose Yes.
5) After the data merge completes, check the results, then save as a .TRX file.

See also: Supported File Formats
Saving Your Changes
Copy and Paste

2.18 Supported Database File Formats
VisiTrax supports the following database file formats:

Standard VisiTrax Library Files (.trx)

This is the recommended format for normal, everyday use. It was designed to contain all of the
information supported by the VisiTrax user interface, plus a number of additional types of information
envisioned for support in future versions of VisiTrax. It also was designed to be saved and loaded very
quickly.

CAUTION: This is a special binary format — do not try to edit one of these files with other
software!

VisiTrax Text File Interchange (VTFI) Text Files (.txt)

This file format, described in more detail on our web site (www.synapsa.com/vtfispec.htm), facilitates
exporting and importing data to or from other applications. You can create and edit files of this format
with an ordinary text editor. (Note that if you have a spreadsheet program, copy and paste might be a
simpler alternative to generating an importable text file.)

Text files generally take significantly more time to read than the .trx format; however, VisiTrax can
merge formatted text files into an existing library. If you open a text file to be read in, and existing
library data is already loaded, you will be asked if the text file data should be merged with the existing
data. If you respond "Yes", the data will be merged; otherwise, any currently open library will first be
closed. Note that the merged data is not saved to a file until you tell VisiTrax to do so.

Saving your data as a text file takes about the same amount of time as saving any other format —
which is to say, almost no time at all.
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Legacy Library Files (.1db)

This format is essentially a very limited subset of the .trx format. It is provided primarily for
back-compatibility with Playlist 4.0x, a DOS-based precursor to VisiTrax that has been in use since
1993. If you have an existing .Idb file created by Playlist 4.0x, you can import it into VisiTrax with no
loss of data.

If you wish to export an existing VisiTrax library to the .Idb file format, only the subset of information
supported by the .Idb format and Playlist 4.0x will be exported. Things to look out for in this regard
include:

¢ Extended volume locators such as "CD0123.1" will be exported without the decimalized digits (e.qg.
"CD0123").

e Track numbers will be limited to 1-99 only. Side A/B information will not be included.

e Invisible CD disc identifiers used to associate CDs with their volumes will not be included.

e BPM, intro times, track filenames, and volume pathnames will not be included.

¢ Playlist-compatible .Idb files require generic ASCII (7-bit) text sorting. VisiTrax automatically ensures
that .Idb file data is sorted this way whenever an existing .Idb file is opened. [Other file types are
opened using a multinational form of ANSI (8-bit) sorting that depends on locale.]

Playlist Files (.vxp)

VisiTrax playlists are saved as ordinary text files, but using a ".vxp" filename extension. A playlist file
contains the playlist's descriptive title on the first line, followed by a set of track identifiers, one line per
track. Each track identifier line consists of an optional volume/track index (e.g. CD0123.1-4), and/or a
hexadecimal CRC (checksum) based on the track's most essential data fields, such as artist and title.
When VisiTrax opens a .vxp playlist file, it looks up tracks based on the CRC, if available, or failing
that, the volume/track index. (Playlists saved by older versions of VisiTrax do not contain CRCs.)

External File Formats

VisiTrax also supports exporting data to some externally-defined file formats. For more information,
see Exporting and Importing Data.

Copy and Paste

With VisiTrax, it's very easy to copy complete listings to and from the Windows clipboard, using a
common tabular form supported by Microsoft Excel and many other programs. While exporting data
from VisiTrax to the clipboard is more or less foolproof, you should be aware that successfully
importing data created by other applications, from the clipboard, requires that the data follows certain
formatting conventions, as described herein.

Copying Data to the Clipboard

To copy (export) the listed items in any of the listing views (Tracks, Volumes, Volume Contents, or
Playlist) to the Windows clipboard, select one of the following from either the Edit menu or the
right-click pop-up menu:

e Copy Main Columns to Clipboard
e Copy Every Column to Clipboard

Each of these has a submenu:

e Select Normal Text Format if you will be pasting into anything other than a spreadsheet (or into a
spreadsheet whose cells have first been preformatted to Text).
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e Select Spreadsheet Compatible if you will be pasting into a spreadsheet program such as Microsoft
Excel This will ensure that times (e.g. "25:32") and hexadecimal values will appear correctly within
the spreadsheet.

A complete export of all tracks and the volumes on which they reside can be obtained by copying
every column to the clipboard from the Tracks view. (If all your volumes contain tracks, this will result
in a complete export of the entire database.)

Shortcut:  Pressing Ctrl-C is equivalent to selecting Copy Every Column to Clipboard > Normal
Text Format.
Pressing Ctrl-X is equivalent to selecting Copy Every Column to Clipboard > Spreadsheet
Compatible.

Pasting Data from the Clipboard

Data copied to the Windows clipboard (as described above, or equivalent) can be pasted (imported)
into the Tracks, Volumes, or Volume Contents view. Each such view requires a different core set of
named columns; any non-relevant columns will be ignored.

Here are some guidelines for successfully importing data into VisiTrax via paste:

1) The order in which columns appear is not important, just the column names. To obtain an example
of the format needed for pasting into a given VisiTrax view, simply press Ctrl-C to copy the data
from that view to the clipboard, then examine it by pasting it into a spreadsheet program or text
editor. You only need to see a few rows of data for this purpose, so you might first want to apply
some filtering to obtain just a small sample.

2) When pasting into the Volumes view, each row must contain, at a minimum, data for
VOLUME_ARTIST, VOLUME_TITLE, and MEDIA_FORMAT, plus a distinct (and valid) INDEX. Any
track-specific information will be ignored.

3) When pasting into the Tracks view, each row must contain, at a minimum, data for ARTIST,
TRACK_TITLE, and CATEGORY, plus sufficient information to identify the containing volume. This
latter can be either the volume's INDEX, if a separate volume table was first pasted into the
Volumes view, or otherwise the VOLUME_ARTIST, VOLUME_TITLE, and MEDIA_FORMAT.

4) When pasting a single, composite table into the Tracks view (i.e. no separate Volumes table), and
a volume INDEX is provided, there is no need to repeat the remaining volume information after the
first row for a given volume. If no INDEX is used, the other required volume fields must exactly
match from track row to track row, for a given volume.

5) When pasting into the Volume Contents view, all pasted tracks will be assigned to the currently
displayed volume. Any volume-specific information will be ignored

6) The GRP_TIME and VOL_TIME columns are ignored, as their data is automatically derived from
track times.

7) A single LOCATION column can be used in lieu of the INDEX and NO. columns.
8) All other columns not specifically mentioned above are optional.

Shortcut:  Pressing Ctrl-V is equivalent to selecting Paste from Clipboard.
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See also: Merging Library Files
Printing CD Labels
Exporting Track Lists
Exporting Volume Lists

Exporting and Importing Data

VisiTrax provides two distinct methods for porting data to or from other applications. Each method has
its distinct advantages.

In most situations, the method of choice will be copying and pasting data, using the Windows clipboard
as an intermediate holding buffer. This method has two key advantages:

e The data is represented as a simple table, compatible with Microsoft Excel and similar spreadsheet
programs.
e Use of the clipboard is much simpler and more foolproof than saving to a file or reading from a file.

The second available method is saving and reading the library data as a text file. This method may be
more advantageous in the following situations:

e Consolidating or renaming artists, media formats, categories, and the like

This entails saving your VisiTrax library as a text file, editing the file with a text editor, then reading
the edited file back into VisiTrax. It's particularly efficient because text files saved from VisiTrax list
distinct names of artists, et al, in sorted order. (Note that reading text files is much slower than
reading .trx files, so you'll normally want to save your data in the standard .trx file form.)

¢ Developing special data conversion utilities

Sometimes the only practical way to port data from another application is by writing a special data
conversion utility. In such cases, the data is often organized as two linked tables, one for albums
(volumes) and one for songs (tracks), making generation of a VisiTrax-readable text file a very
straightforward operation.

While the text file format provides a much more efficient data representation compared to the tabular
form used by copy and paste, it's generally a more complex layout.

See also: Merging Library Files
Printing CD Labels
Exporting Track Lists
Exporting Volume Lists

Exporting Track Lists
VisiTrax supports exporting lists of tracks to ready-to-upload files for the following on-line services:

¢ DJ Intelligence (www.DJIntelligence.com)
e GigBuilder (www.gigbuilder.com), a WeDJ.com subsidiary site.

Track lists also can be exported to generic CSV format files, for use with applications that import CSV
files, such as MobileDB-PC or Microsoft Excel.

Track listings can be exported from the Tracks view, Volume Contents view, or Playlist view. To export
a tracks listing, do the following:
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1) Establish the list of tracks to be exported by selecting the desired view and any applicable filters.
2) From the File menu, choose Export Track List.

3) From the submenu that appears, choose the type of export file desired.

4) From the Export list to file dialog, select the desired folder and file name.

5) For ready-to-upload files, follow the on-line service's documented procedure for uploading the file.

DJ Intelligence files (default name DJl.csv) will contain data, with no heading row, from the following
columns:

o Artist

e Track Title

¢ Category

e Year (as 5-year ranges)
e Location

GigBuilder files (default name GigBuilder.csv) will contain data, with a heading row, from the
following columns:

o Artist

e Track Title

¢ VVolume Title

e No. (track number)

e Year

e Time

e BPM

e Locator (volume index plus track number)
o Category

¢ Media Format

e Track Notes (length-limited); or Composer if no Track Notes
¢ Folder plus File Name

Generic CSV format track list files (default name tracks.csv) will contain (as a minimum) the main
viewable set of columns, with a heading row. In addition, the following columns will always be included:

o Artist

e Track Title

o Category

e Composer (or Track Notes if no composer)
e Year

e Time

e Intro time

e BPM

¢ No. (track number)

¢ Index (of volume)

e Locator (volume index plus track number)
¢ Media Format

¢ VVolume Artist

e \VVolume Title

e Folder

e File Name
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2.23

See also: Exporting and Importing Data
Copy and Paste
Merging Library Files
Printing CD Labels

Exporting Volume Lists

To export a list of volumes to a generic CSV format file that can be imported by MobileDB-PC,
Microsoft Excel, or similar application, do the following:

1) Establish the list of volumes to be exported by selecting Volumes view and any applicable filters.
2) From the File menu, choose Export Volume List.
3) From the Export list to file dialog, select the desired folder and file name.

The resulting CSV file (default name volumes.csv) will contain (as a minimum) the main viewable set
of columns, with a heading row. In addition, the following columns will always be included:

¢ VVolume Artist

e VVolume Title

¢ Volume Category
e Volume Year

e Volume Time

e Index

e Media Format

See also: Exporting and Importing Data
Copy and Paste
Merging Library Files

Creating Cross-References

Sometimes you might want to establish a cross-reference between an individual artist and other artists
or groups, so that you can more readily locate everything you have related to that artist. Here's how
you can do this:

1. For each individual artist needing a cross-reference, create a cross-reference volume record,
entitled (Related Groups). For the media format, use Cross Reference (suggested location
index prefix: XR).

2. Create one track entry in this volume for the individual artist, entitled * See also... — the Category
field can be anything.

3. Create one track entry in this volume for each related group, entitled * See also <artist name> —
for example, if the artist name is John Lennon, use * See also Lennon, John for the track title for
each related group.

The use of cross-reference entries as outlined above will result in a Tracks view similar to this:
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VisiTrax - N:\Synapsa Productions\VisiTrax\Music.trx g@
File Edit Wew Sorting Extras Help
poed & BREHE Y A
kedia Format: I ;I Artist: I ;I
Cateqary: I ;I Title: I ;l
Composer: I ;I MHates: I ;I
Year Autist | Track Title | Time | vear| Location "A]
I ,I Beach Boys You'me So Good to Me 214 1963 LPOO18ER3
Beach Boys You'me So Good to Me 2716 | 1963 CDOO0O7-19 [g]
i) . |BeastieBoys  Sabotage 255 AFDO0T
I jﬂ Beatles * See alzo Harrizon, George *RO0005
Max Time Beatles * See alzo McCartney, Paul *R0008
Beatles * See alzo Star, Ringo *R0015
Y i Beatles A Day in the Life 5:33 ) 1967 CDO01913
SaMN | |Beatles £ Hard Day's Might 228 | 1964 | LPOD21.1-B1
[ 15 EI Beatles A Hard D ay's Night 232 | 1964 CDO0O3
Beatles A Hard Day's Might 2:43 1995 CDO020.2412
Beatles A Taste of Honey 205 | 1963 CDOOME12
Show Al Baatles Aicross the Universs 350 | 1969 COO01513 ]
£]u (]
Tracks I‘Jnlumes I Yolume Contents Playlistl CD Player I
=RO007 [Rock and Roll] |F'Ia_l,l|ist total = 55:44 |Tlacks: E5e0/B580 4

Note how the use of asterisks keeps all of the Beatles cross-reference entries grouped together at the
beginning.

If you double-click on the * See also Lennon, John entry, you'll see a Volume Contents view similar to
this:

VisiTrax - N:\Synapsa Productions\VisiTrax\Music.trx g@
File Edit Wiew Extras Help

Ded & 99V as

Lennon, John: (Related Groups)

Mo, | Track Title | Artigt | Cateqgary | bpml Tirne | Inlru:nl Year

*See alzo... Lennon, John Rock and Rl
* See alzo Lennon, John Lennon, Jobn & Yoko Fock and Roll

£ ] (&
Tracks I Yolumes Valume Contents I Playlist I CD Player I
Fock and Roll |F'Ia_l,l|ist total = 55:44 |><FH:IEIEI?' - Crogs-reference [(00) 2

If you then double-click on the second track entry above, you'll be taken to a Tracks view similar to
this:
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VisiTrax - N:\Synapsa Productions\VisiTrax\Music.trx g@
File Edit Wiew Sorting Extras Help
poed & BREHE Y A
kedia Format: I ;I Artist: I ;I
Cateqary: I ;I Title: I ;l
Composer: I ;I MHates: I -
Year Autist | Track Title | Time | vear| Location I_A_
I ,I Left Banke Pretty Ballerina 2:34 | 1968 SG0003-14
Left Banke wWalk Away Fenee 241 1966 CDO175-8
i) _,|LemonDrops 1 Live in the Springtime 264 1967 CD0233-22
I jﬂ Lemon Fipers | Green Tambourine 222 1967 SGO002-67
Max Time Lernan, John | God 404 LPO0BEES |
Lennan, John | kother 529 LPO0E5-41 =
Y i Lennon, Johh  |'working Class Hero 344 LP 008544
as - Hin |/ ILennan, John .. * See alsa Lennan, John *RO007
I 15 II Lennon, John ... | Instant Karma 316 AF 0007
Lennan, John ... | Ikstant Karma 318 SGEO005-H
Lennan, John ... | Woman 330 SGEO007-46 a
Show A _Le_nny Krawitz Again 348 | 2000 |CDOZZ4-4 |
.< J .>.
Tracks I‘Jnlumes I Yolume Contents Playlistl CD Player I
=RO007 [Rock and Roll] |F'Ia_l,l|ist total = 55:44 |Tlacks: E5e0/B580 4

One final note here: Cross Reference, (Related Groups), and * See also... are merely suggested
naming conventions. They have no special meaning to VisiTrax. The punctuation we've suggested
makes it evident that these are cross-reference entries, as opposed to real volume entries.

2.24 Checking for Updates

From time to time, new improved versions of VisiTrax will be made available on our web site. To
determine if the version you have installed is current, select About... from the VisiTrax Help menu,
and compare the version number shown there against the version shown on our web site.

2.25 Viewing Database Statistics

To view a statistics summary for the currently loaded database, choose About... from the Help menu.
This will bring up the About VisiTrax dialog, which also displays the program's version level.

2.26 Exiting from VisiTrax

If you have library file changes pending when you exit VisiTrax, you will be asked if you want the
changes saved, and given three options:

e Yes — Update the file and then quit.
e No — Quit without updating the file (discards any changes you made).
e Cancel — Don't quit (cancel your exit request).

See also: Saving Your Changes
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3 VisiTrax Display Options

3.1 View Options and Customization
To customize the appearance and general user interface features of VisiTrax:
e You can resize the main VisiTrax window and certain controls.
e You can select and reorder which data columns you normally see.

e From the right-click pop-up menu, you can configure fonts, colors, and grid lines in the listing
views.

e From the View > Starting View menu, you can select your preferred starting view.

¢ Lastly, from the View > Options menu, you can select various general preferences, including
automatic CD recognition, pop-up hints, confirmation before deleting volumes or tracks.

3.2 Resizing

General Resizing Features

The entire VisiTrax window can be resized, using any of the standard Windows resizing methods.
The Add New Volume and Add New Track dialogs, and the corresponding Volume Details and Track
Details dialogs, likewise can be resized in similar fashion.

Listing View Resizing Features

In any of the list grids, any columns containing non-formatted data, such as the Artist or Title
columns, can be resized by by dragging their divider on the heading bar. Double-clicking this divider
automatically sets the column's width based on the widest data it contains. To reset the column
proportions back to their initial defaults, choose Reset Column Widths from the View menu.

Above the list grid in the Tracks and Volumes views, you can drag the vertical divider to adjust relative
widths of the left and right sets of filter fields (handy if you have some unusually long category
descriptions, for example).

CD Player View Resizing Features

On occasion, you might want to adjust the relative sizing of sections within the CD Player view. To
temporarily adjust relative widths, you can "grab" any of four vertical resizing bars with your mouse and
move them left or right as desired.

You also can "grab" the top edge of the lower panel containing the track-specific information, and
move it up or down to temporarily adjust relative heights.

See also: Fonts, Colors, and Grid Lines

3.3 Changing Which Columns You See
In each library listing view, the columns are divided into two sets:

e The main columns are automatically kept sized as a group to match the listing window's width, by
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scaling variable-width columns proportionally as needed.

¢ Any columns you can access by scrolling to the right are extra columns. Extra columns have a
grayed-out appearance along with dark blue heading text, so they can be distinguished readily from
the main columns.

To change the relative position of any column, simply drag it by its header to the left or right. To "hide"
one of the main columns, drag it to the right into the set of extra columns. To "show" one of the extra
columns, drag it to the left into the set of main columns.

Column positions and relative proportions are retained when you exit VisiTrax. Each time VisiTrax
starts up, the initial sorting order for both the Tracks and Volumes views is set in descending column
precedence from left to right, such that initially, the leftmost column will be the primary sort column.

Example #1: Hiding (demoting) a column

In this example, we will remove the bpm column from view. Perform these simple steps:

¢ Click down on the bpm header. Note the vertical position bar that appears.

¢ While still holding down the mouse button, drag the vertical position bar to the right edge of the
window.

¢ Release the mouse button. The bpm column will have moved off to the right, out of view. Notice that
the variable-width columns automatically resize for you, to make use of the available window width.

Artist | Track Title | Category | bpm, | Time | Location
1, o .
B-52's Bad Influsnce Fock My 4 cho241-10 Button down
Artist | Track Title | Category || bpm | Time | Location
B-52's Bad Influence Rock 119% 541 CDO241-10 Drag right
Artist | Track Title | Category | bpml Time | Location
B-52's Bad Influsnce Fock 118 41 CDoz241-10 Button up
Artist | TrackTtle | Category | Time | Location
B-52's Bad Influsnce Fock S CD0241-10

Example #2: Promoting an extra column into the main view set

In this example, we will bring the Year column into view. Perform these steps:

o Scroll the grid listing to the right, using the horizontal scroll bar at its bottom, until you see the column
you want (in this case, Year). Note that the extra columns are grayed out, and their headings are
colored dark blue rather than black.

¢ Click down on the Year header. Note the vertical position bar that appears.

¢ While still holding down the mouse button, drag the vertical position bar to the left, until it reaches the
new position you want. Note that the new position needs to be to the left of at least one of the
main columns (in this case, Location); otherwise the extra column won't be promoted to a main
column.

¢ Release the mouse button. The Year column is now in the main set of columns.

o Scroll the grid listing back to the left, so you see the normal, main set of columns. Note that the
adjustable width columns (in this case Artist, Track Title, and Category) gave up some of their
width to make room for the added Year column.

Track Title

Location

Artist |

| Category | Time |

B-52's

Bad Influence

Rock

w41 Co0241-10

Scroll right

Category | Time |

Location

| bpm | ‘r‘earl Ma. |

Track Suk

Rock

w41 Co0241-10

1149

1992

i Choose column
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Categary | Time | Lacation | bpm | “ear | Ma. | Track Sul
Rock S:41 (CDO241-10 119 19924y 10, Button down
Categary | Time | Lacation | bpm || Year | Ma. | Track Sul
Rock S:41 (CDO241-10 119 §1992%y 10, Drag left
Categary | Time Location | bpm | “ear | Mo, | Track Sul
Rock S:41 0024110 %‘ 119 1992 10, Button up
Category | Time | ear | Location | bpm | Mo, | Track Subti
Rock S41 1992 CDOZ41-10 ¥ 119 10, Scroll back
Artist | Track Title | Categary | Time | “ear | Location
B-52's Bad Influence Rock 241 1992 CDo241-10

Example #3: Swapping the rightmost two main columns

We include this last example because assigning a new rightmost column is a special situation. In this
example, we'll swap the Location and Year columns. Note that if you tried doing this by dragging the
Location column to the right, you'd actually have an instance of Example #1, above (i.e., you'd end up
removing the Location column from view). So the thing to remember here is to move the rightmost
column to the left, instead:

¢ Click down on the Year header. Note the vertical position bar that appears.

e While still holding down the mouse button, drag the vertical position bar to the left of the Location
column.

¢ Release the mouse button. The Year and Location columns will have exchanged positions.

Artist |
B-52's

Track Title
Bad Influence

| anr
19% | Bytton down
|| anr
1132 | prag left

|Categc-r\,n'| Time | Location
Rock 41 COO241-10

Artist |
B-52's

Track Title
Bad Influence

|Categc-r\,n'| Time | Location
Rock 41 COO241-10

Artist

| Track e

| Categary |

Titme:

Location

| Year

B-52's

Bad Influence

Rock

o

D0241-100%

1982

Button up

Artist

Track Title

| Categary | Time | Year |

Location

B-52's

Bad Influence

Rock

o

1992 | CDOAH-10

See also: Resizing

3.4 Fonts, Colors, and Grid Lines

The following portions of the VisiTrax display can be tailored for fonts, background color, and grid
lines:

e The Tracks View grid

e The Volumes View grid

e The Volume Contents View grid, as well as its heading bar above the grid
e The Playlist View grid, as well as its heading bar above the grid

To change the display characteristics for any of the above, place the mouse cursor over the area of
interest and click the right-hand button for a "right-click" list of options. (For grid characteristics, this
menu can also be accessed via Alt-P).

The view selection tab fonts can be changed by selecting Tabs Font from the main listing area's
right-click menu.
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3.5

3.6

In addition, the View > Options menu contains a Light Dialog Fonts option, which switches between
a lighter or heavier default font style for VisiTrax dialogs. This affects, for example, the font style used
for the status bar, filter controls in the Tracks and Volumes views, and the volume and track editing
dialogs.

See also: Printing Options

Starting View

Normally, VisiTrax starts up in the Tracks view. However, you can change this by selecting one of the
following options in the View > Starting View menu:

Tracks The Tracks view is selected by default

Volumes The Volumes view is selected by default

CD Player The CD Player view is selected by default

Most Recent  One of the above, based on the view you were in when you previously used
VisiTrax.

General Preferences
The View > Options menu offers the following preference settings:

Data Entry Box Colors This contains a short submenu (Custom vs. Standard). Selecting Custom
permits you to select a single custom background color for most data entry
boxes. Selecting Standard will apply the default Window background color
(as defined in your general Windows display settings).

Splash Banner on Startup When checked (default), displays a "VisiTrax" splash banner graphic
during program startup. The main purpose of the splash banner is to provide
a more immediate indication that the program is starting. If you have an
aversion to such things, you can uncheck this option to inhibit the splash
banner; however, we doubt you will see any noticeable difference in program
startup speed.

Hint Popups When checked (default), enables the display of pop-up hints (also known as
"tool tips"). These can come in handy when you're first starting out, but
some experienced users may prefer to disable them.

Light Dialog Fonts Determines the font style used within most VisiTrax dialogs.

Confirm on Delete When checked, causes a confirmation dialog to appear prior to deleting a
track or volume. Since VisiTrax also has an Undelete feature, you may find
it more productive to work without delete confirmation.

Enable Print Preview  Enables or disables display of the Print Preview dialog prior to printing. If
disabled, a simple pop-up dialog will be displayed instead.

Auto-detect CDs When checked, will cause VisiTrax to switch to the CD Player view
automatically when an audio CD is inserted.

Auto-connect to Server When checked, will cause VisiTrax to automatically enable access to the
previously selected CD data server whenever the CD Player view is used.
This is most useful if you have a continuous Internet connection.

Copyright 1999-2023 Synapsa Productions



Printing with VisiTrax a7

4.1

Printing with VisiTrax

Printing and Print Preview

VisiTrax can print lists of tracks, lists of volumes, tracks in a selected volume, and playlists. You can
initiate printing in any of the following ways:

« Click on the & toolbar button
e Select Print Listing... from the File menu
e Type Ctrl-P

Print Preview and Page Selection

Whenever you initiate printing using one of the above methods, a Print Preview dialog will appear
(unless you have disabled this feature; see the Note, below). From this dialog, you can preview on the
screen how each printed page will appear, and select page layout, orientation, and the range of pages
to print.

The Print Preview dialog provides a scrollable page preview panel, plus the following controls:

Page layout There are two primary layout modes. In Automatic mode, a fixed set of
commonly-used data fields will be printed using an efficient presentation style.
The set of fields chosen and their layout are tailored for each type of view.

The Columns as shown mode (the default) is more flexible. In this mode, the
printout will correspond to the main set of columns you have selected for the
current view, as well as their ordering and relative width proportions. For still
more flexibility, the Duplicate suppression and Indented subheadings
controls are also available in this mode.

Orientation This provides convenient switching between Portrait and Landscape page
orientation.
Page range This lets you select the page or range of pages to be printed.

Duplicate suppressionThis control is only available for the Columns as shown page layout, which
normally will suppress any row that duplicates data in the all columns of the
preceding row. Use this control to reduce the number of leftmost columns
compared to the preceding row. For example, if the printout contains 5
columns and this control is set to 4, any row in which columns 1 through 4 are
the same as in the preceding row will be suppressed, even if column 5
contains different data.

Indented subheadings This set of controls is only available for the Columns as shown page
layout, in which, by default, all data is printed in tabular columns, with headings
that name each column.

To print the first one or more columns of data as indented subheading levels,
set Subhead levels to the number of subheading levels you want. Headings
will appear only above any remaining columns.

Ordinarily, each subheading level will use the data from each of the first
columns, in left-to-right order. However, if the first n data columns are
fixed-width fields (e.g. track number, index, year), you can combine up to the
first n+1 data columns into the first subheading level, via the Join columns...
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control.

Despite consuming a bit more paper, subheadings are invaluable for reducing
or eliminating data truncation, and the resulting printouts tend to be more
aesthetically appealing.

Additional lines This control is only available for the Columns as shown page layout, in which,
by default, all data is printed in tabular columns, with headings that name each
column. However, some columns may be empty much of the time, or they may
contain notes or other lengthy material. To print such data as one or more
additional lines of text, first arrange the corresponding columns so they appear
last, then set the Notes columns control to the number of columns you want
printed as additional lines.

For example, to print Track Notes as additional lines, arrange your main
columns so that Track Notes appears last, then set Notes columns to 1.

Print This button prints the page or range of pages indicated in the Page range
control.

Setup This button is used to access a menu of font setting and printer setup options.

Done Click this button when you are done with the Print Preview dialog.

Note: To enable or disable Print Preview, select Options > Enable Print Preview from the View
menu. When Print Preview is disabled, a simple pop-up dialog will appear instead. (However, note
that some advanced features, such as indented subheadings, are available only via the Print Preview
dialog.)

Printer Selection and Page Orientation

Before printing, you can change printer settings or page orientation by selecting Printer Setup... from
the File menu, or by selecting Setup > Printer Setup from the Print Preview dialog. This brings up a
standard printer setup dialog for your particular model of printer. The settings you make here will apply
to all printouts. (Page orientation can also be changed via the Print Preview dialog's Orientation
control.)

Print Font Selection

To change the fonts used by VisiTrax to print your listings, select Printer Fonts from the File menu, or
select Setup from the Print Preview dialog. From the submenu, you can select any of the following:

e Page Title Font

e Column Heading Font

e Subheading 1 Font (first-level subheadings)

e Subheading 2 Font (second-level subheadings)

e Subheading 3 Font (third-level subheadings and any beyond that)
e List Items Font

e Notes Font (additional lines of text)

If you use a color printer, you may wish to assign colors to some of these fonts.

Reminder: When printing from the Playlist View, the page title is taken from that view's playlist title,
which can be directly edited.
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4.2

Printing CD Labels

VisiTrax supports use of SureThing CD Labeler (version 3 or later), a design and printing tool for CD
labels, jewel case inserts, and related matter. Two alternative methods are available:

e Print to CD Labeler — This option, selected from the File menu, activates the CD Labeler program
and opens a new design window, with an active playlist containing a track listing selected from
VisiTrax.

e Copy as CD Labeler Playlist — This option, selected from either the Edit menu or the right-click
menu, copies a selected VisiTrax track listing to the Windows clipboard as an Audio CD playlist, then
activates CD Labeler without creating a new design window. If you are using SureThing CD Labeler
Deluxe, which supports playlist copy and paste, you can then paste the track listing into the current
design's active playlist.

Note 1: These two menu options are available only if CD Labeler is installed on your computer.

Note 2: CD Labeler uses the term "playlist" to denote a list of titles, artists, etc. for a single CD.
This should not be confused with "playlist” as generally used within VisiTrax.

Selecting a Track Listing Source from VisiTrax

For either transfer method described herein, you first need to select the track listing source:

From the Volumes view: tracks will be taken from the selected volume.

From the Tracks view: tracks will be taken from the selected track's volume.

From the Volume Contents view: all listed tracks will be taken.

From the Playlist view: all listed tracks will be taken (the CD title will be taken from the first listed
track's volume).

Using "Print to CD Labeler"

To use this option, perform the following steps:
(1) Select the track listing source from VisiTrax, as described above.

(2) Select Print to CD Labeler from the File menu. If you are in the Tracks or Volumes view,
VisiTrax automatically switches to the Volume Contents view.

(3) A file selection dialog will appear. Select the label design set file to be used, then click Open.

(4) CD Labeler automatically activates, opening a new design window using the selected label design
set and track listing.

(5) Refer to CD Labeler's documentation for help on making any necessary layout adjustments and
printing.

(6) You can switch back and forth between VisiTrax and CD Labeler as often as you like; there is no
need to close either program until you are all done with it.

Using "Copy as CD Labeler Playlist”

This option takes advantage of the "playlist paste" feature available in SureThing CD Labeler Deluxe.
It is not intended for use with more limited versions of CD Labeler that don't have this feature. The
main advantage of this option is that it avoids opening a separate design window for each track playlist
imported from VisiTrax, since it's basically a copy/paste operation.
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5.1

To use this option, perform the following steps:
(1) Select the track listing source from VisiTrax, as described above.

(2) Select Copy as CD Labeler Playlist from either the Edit menu or the right-click pop-up menu (or
press Ctrl-L). This does the following things:

If in the Tracks or Volumes view, VisiTrax automatically switches to the Volume Contents view.
Data is copied to the clipboard as a CD Labeler Audio CD playlist.

The CD Labeler program is activated automatically.

If a label design form is open, the Edit Active Playlist dialog is activated (from CD Labeler's
Playlists menu).

(3) Click the B button at the bottom of the Edit Active Playlist dialog, to paste the clipboard data into
CD Labeler's currently active playlist.

(4) Within CD Labeler, select the label format, style, and playlist fields you wish to use. (To include
playlist fields on a label, select Insert Playlist Fields from the Playlists menu.) You can do this
either before or after steps (1) and (2).

(5) You can switch back and forth between VisiTrax and CD Labeler as often as you like; there is no
need to close either program until you are all done with it.

Refer to CD Labeler's documentation for additional help.

Tip: With SureThing CD Labeler Deluxe, you can quickly create a ready-to-use "starter" set of CD
labels, complete with playlist fields, using the New CD Wizard. Select the "Audio CD"
SmartDesigns option.

For additional information on using playlists within CD Labeler Deluxe, please refer to their tutorial

entitled "Working with Playlists”, and in particular their tutorial subtopic entitled "Adding Playlist Fields
to an Existing Design".

Appendix

Definitions
The terms appearing below have special meaning when used in conjunction with VisiTrax:

Playlist A playlist is a playing schedule for selected tracks residing in any arbitrary set of volumes
in the library.

Typical uses for a playlist might include scheduling of a program for use by a DJ, or
defining material to be transcribed onto a tape or CD.

Swiping This is a lot like drag and drop, except you don't have to move the mouse pointer very far
at all.

To perform a swipe action, move the mouse cursor to the right or left a short distance
while holding down the left mouse button, then release the button, all while remaining
within the currently-highlighted line.

Track A track is any discrete selection, song, tune, cut, video, etc. VisiTrax is designed to
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instantly locate individual tracks in your music library, regardless of their associated
media.

At a minimum, each track has a defined artist name, title, and category (e.g. Classical,
Folk Music, Rock, or any other description you might wish to use). Optionally, a track can
have an index number, playing time, year, etc. File names can be specified for
computer-based tracks (e.g. MIDI or WAV files).

Volume A volume is any logical grouping of tracks sharing a common container, such as an
album, tape, compact disc, box or tray, etc.

At a minimum, each volume has attributes of artist, title, and media format (e.g. 33 RPM
Album, Compact Disc, DVD, or any other description you might wish to use). For
computer-based tracks, such as MIDI and WAV files, a single directory pathname can be
specified for a given volume.

5.2 End-User License Agreement

This is a legal agreement between you (either an individual or a single entity) and us (Synapsa
Productions and/or the author) for the Software Product called "VisiTrax", including all associated
executable and data files provided therewith. You may install and use this Software Product if and only
if you concur with the terms of this Agreement.

Copyright

All rights, title, and copyrights in and to this Software Product, and any copies thereof, are owned by
the author(s) of this software. This Software Product is protected by copyright laws and international
treaty provisions. Therefore, you must treat it like any other copyrighted material, except as specified
otherwise herein.

You may not reverse-engineer, decompile, disassemble, or modify any copy of this Software Product,
nor otherwise attempt to circumvent any protective mechanism thereof, including but not limited to
attempted use of any unauthorized software key; except and only to the extent that such activity is
expressly permitted by applicable law notwithstanding this limitation.

You are permitted to give copies of this Software Product to others, in any reasonable distribution
format (e.g. diskette, CD-ROM, e-mail, FTP), as long as the original package remains unmodified.
Embedding the original package within a single compression/archive format (e.qg. zip, arj, tar) is
permitted, as long as the original package can be extracted intact. "Original package", as used herein,
means the single, executable program file we distribute that is used to extract and install a usable copy
of the Software Product on a computer.

No restriction is made concerning fees for copying, transmission, or storage.

Licensed Software

VisiTrax is licensed. It is not, and shall not be, sold, rented, or leased. If you are a vendor, you may not
represent this Software Product to others in any manner inconsistent with this License Agreement.

Termination

This Agreement shall immediately and automatically terminate without notice if you fail to comply with
any term or condition of this Agreement. You agree upon termination to promptly cease use of the
Software Product and to destroy all copies thereof.

Export Restrictions
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You agree that neither you nor your customers intend to or will, directly or indirectly, export or transmit
any portion of this Software Product to any country to which such export or transmission is restricted
by any applicable U.S. regulation or statute, without the prior written consent, if required, of the Bureau
of Export Administration of the U.S. Department of Commerce, or such other governmental entity as
may have jurisdiction over such export or transmission.

United States Government Restricted Rights

VisiTrax and its documentation are provided with RESTRICTED RIGHTS. Use, duplication, or
disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the
Rights in Technical Data and Computer Software clause at DFARS 252.227- 7013 or subparagraphs
(c)(1) and (2) of Commercial Computer Software - Restricted Rights at 48 CFR 52.227-19, as
applicable. Manufacturer is Synapsa Productions, 217 Victory Lane, Harvester, Missouri, 63303-8432.

No Warranty

To the extent permitted by applicable law, we expressly disclaim any warranty for this Software
Product. This Software Product is provided "as is" without warranty of any kind, either express or
implied, including, without limitation, the implied warranties of merchantability or fitness for a particular
purpose. The entire risk arising out of use or performance of this Software Product remains with you.

General

Should any part of this Agreement be declared void or unenforceable by any court of competent
jurisdiction, such declaration shall have no effect on the remaining parts hereof.
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